summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2021-06-30 21:48:15 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-07-15 02:01:13 -0400
commit27f298f964bf756128a2e75773dd3619cd4eb25b (patch)
tree360f98b1e78e06fc21d9f15d729bed847e1f8595 /dev-libs/libtpms
parentapp-emulation/xen-pvgrub: drop last-rited package (diff)
downloadgentoo-27f298f964bf756128a2e75773dd3619cd4eb25b.tar.gz
gentoo-27f298f964bf756128a2e75773dd3619cd4eb25b.tar.bz2
gentoo-27f298f964bf756128a2e75773dd3619cd4eb25b.zip
dev-libs/libtpms: Bump to 0.8.4
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21492 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-libs/libtpms')
-rw-r--r--dev-libs/libtpms/Manifest1
-rw-r--r--dev-libs/libtpms/libtpms-0.8.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libtpms/Manifest b/dev-libs/libtpms/Manifest
index ed6e38e9225e..06243131e7de 100644
--- a/dev-libs/libtpms/Manifest
+++ b/dev-libs/libtpms/Manifest
@@ -1 +1,2 @@
DIST libtpms-0.8.3.tar.gz 1254474 BLAKE2B c71f52d6475d4328e93a35f88557de3400308984ec086f7e6b3c32ebc266e078b3a9864396546ba11fc310c1572efa1521bdac89075c5eba18cb35eef883e706 SHA512 07cf78c2a5b03f3c9179b041db57d5ec049dc0085c09e4fd5c9b54a247cf81a3b9982f0fb1cd571cd6b21b3d9824b061f8f38508fc25b6a23a6a6b06dea7115b
+DIST libtpms-0.8.4.tar.gz 1255255 BLAKE2B 0786b19dc8f3226508548ab16544ee8ac05e8d9de057eed840a0cb7577c1d1386d83af1a725ec91e64344e2459f9d4836268e2c9a097136cf76d59ea8e23b0c8 SHA512 58244a774cb6ec5dcbbc2d795628fca9eb64936874c72b169ea8288f2bf0cafa8127b1e89ed3ddbf5694df5a5944a7d61254dc729d75b63b3e4f9346b2f0a7b5
diff --git a/dev-libs/libtpms/libtpms-0.8.4.ebuild b/dev-libs/libtpms/libtpms-0.8.4.ebuild
new file mode 100644
index 000000000000..3eab05684d98
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.8.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc"
+
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-openssl \
+ --with-tpm2
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 0.8.0; then
+ elog "Versions of libtpms prior to 0.8.0 generate weaker than expected TPM 2.0 RSA"
+ elog "keys due to a flawed key creation algorithm. Because fixing this would render"
+ elog "existing sealed data inaccessible, to use the corrected algorithm, the old"
+ elog "TPM state file must be deleted and a new TPM state file created. Data still"
+ elog "sealed using the old state file will be permanently inaccessible. For the"
+ elog "details see https://github.com/stefanberger/libtpms/issues/183"
+ fi
+}