summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-01-12 16:09:48 +0100
committerFabian Groffen <grobian@gentoo.org>2024-01-12 16:11:29 +0100
commitc1863cfc833846a75595a25442d2ad191716a798 (patch)
treed16a7141c63af6d0e950c898601b44611a205fa9 /dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild
parentapp-admin/mcelog: add 197 (diff)
downloadgentoo-c1863cfc833846a75595a25442d2ad191716a798.tar.gz
gentoo-c1863cfc833846a75595a25442d2ad191716a798.tar.bz2
gentoo-c1863cfc833846a75595a25442d2ad191716a798.zip
dev-libs/libtomcrypt: unbreak on Darwin
We force LIBTOOL to libtool, assuming it is a script bash can execute, but on Darwin -- historically -- libtool is a linker helper which isn't quite the same as GNU libtool. The upstream buildsystem knows this, and deals with it, but our override squashes that, of course. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild')
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild b/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild
index a42911b32ece..cc30adcd38f5 100644
--- a/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild
+++ b/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild
@@ -77,7 +77,11 @@ mymake() {
fi
# Fix cross-compiling, but allow manual overrides for slibtool, which works.
- [[ -z ${LIBTOOL} ]] && declare -x LIBTOOL="${BASH} ${ESYSROOT}/usr/bin/libtool"
+ if [[ -z ${LIBTOOL} ]] ; then
+ local pfx=
+ [[ ${CHOST} == *-darwin* ]] && pfx=g # Darwin libtool != glibtool
+ declare -x LIBTOOL="${BASH} ${ESYSROOT}/usr/bin/${pfx}libtool"
+ fi
# IGNORE_SPEED=1 is needed to respect CFLAGS
EXTRALIBS="${extra_libs[*]}" emake \