summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Whitlock <gentoo@mattwhitlock.name>2023-01-06 17:00:40 -0500
committerSam James <sam@gentoo.org>2023-01-07 07:39:56 +0000
commit92347c4b7a1c06bc03a6f258a3f53c22a503ae2e (patch)
tree98011e77226b7f4a4f3da9d5affd7320c043df81 /dev-libs/libsecp256k1
parentdev-libs/libsecp256k1: enable USE="ecdh" by default (diff)
downloadgentoo-92347c4b7a1c06bc03a6f258a3f53c22a503ae2e.tar.gz
gentoo-92347c4b7a1c06bc03a6f258a3f53c22a503ae2e.tar.bz2
gentoo-92347c4b7a1c06bc03a6f258a3f53c22a503ae2e.zip
dev-libs/libsecp256k1: drop "precompute-ecmult" USE flag
And change the ecmult window size for USE="lowmem" from 2 to 4. Suggested-by: Tim Ruffing <crypto@timruffing.de> See: https://github.com/bitcoin-core/secp256k1/pull/1159#issuecomment-1323523530 See: https://gitlab.com/bitcoin/gentoo/-/commit/6e39601a748f3465f66a38e7989e7414a4a1d9c0 Signed-off-by: Matt Whitlock <gentoo@mattwhitlock.name> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libsecp256k1')
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-0.1_pre20201028-r1.ebuild (renamed from dev-libs/libsecp256k1/libsecp256k1-0.1_pre20201028.ebuild)8
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-0.2.0-r2.ebuild (renamed from dev-libs/libsecp256k1/libsecp256k1-0.2.0-r1.ebuild)6
-rw-r--r--dev-libs/libsecp256k1/metadata.xml3
3 files changed, 6 insertions, 11 deletions
diff --git a/dev-libs/libsecp256k1/libsecp256k1-0.1_pre20201028.ebuild b/dev-libs/libsecp256k1/libsecp256k1-0.1_pre20201028-r1.ebuild
index b78335558ac9..ae79e2f9f11b 100644
--- a/dev-libs/libsecp256k1/libsecp256k1-0.1_pre20201028.ebuild
+++ b/dev-libs/libsecp256k1/libsecp256k1-0.1_pre20201028-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,13 +14,12 @@ SRC_URI="https://github.com/bitcoin-core/${MyPN}/archive/${COMMITHASH}.tar.gz ->
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="+asm ecdh +experimental +extrakeys gmp lowmem precompute-ecmult +schnorr +recovery test test-openssl valgrind"
+IUSE="+asm ecdh +experimental +extrakeys gmp lowmem +recovery +schnorr test test-openssl valgrind"
RESTRICT="!test? ( test )"
REQUIRED_USE="
asm? ( || ( amd64 arm ) arm? ( experimental ) )
extrakeys? ( experimental )
- ?? ( lowmem precompute-ecmult )
schnorr? ( experimental extrakeys )
test-openssl? ( test )
"
@@ -63,8 +62,7 @@ src_configure() {
--with-bignum=$(usex gmp gmp no) \
$(use_enable recovery module-recovery) \
$(use_enable schnorr module-schnorrsig) \
- $(usex lowmem '--with-ecmult-window=2 --with-ecmult-gen-precision=2' '') \
- $(usex precompute-ecmult '--with-ecmult-window=24 --with-ecmult-gen-precision=8' '') \
+ $(usex lowmem '--with-ecmult-window=4 --with-ecmult-gen-precision=2' '') \
$(use_with valgrind) \
--disable-static
}
diff --git a/dev-libs/libsecp256k1/libsecp256k1-0.2.0-r1.ebuild b/dev-libs/libsecp256k1/libsecp256k1-0.2.0-r2.ebuild
index 4808a250ea87..9391a6c99236 100644
--- a/dev-libs/libsecp256k1/libsecp256k1-0.2.0-r1.ebuild
+++ b/dev-libs/libsecp256k1/libsecp256k1-0.2.0-r2.ebuild
@@ -13,11 +13,10 @@ SRC_URI="https://github.com/bitcoin-core/secp256k1/archive/v${PV}.tar.gz -> ${P}
LICENSE="MIT"
SLOT="0/1" # subslot is "$((_LIB_VERSION_CURRENT-_LIB_VERSION_AGE))" from configure.ac
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+asm +ecdh experimental +extrakeys lowmem precompute-ecmult +schnorr +recovery test valgrind"
+IUSE="+asm +ecdh experimental +extrakeys lowmem +recovery +schnorr test valgrind"
RESTRICT="!test? ( test )"
REQUIRED_USE="
- ?? ( lowmem precompute-ecmult )
asm? ( || ( amd64 arm ) arm? ( experimental ) )
schnorr? ( extrakeys )
"
@@ -46,8 +45,7 @@ src_configure() {
$(use_enable {,module-}extrakeys)
$(use_enable {,module-}recovery)
$(use_enable schnorr module-schnorrsig)
- $(usev lowmem '--with-ecmult-window=2 --with-ecmult-gen-precision=2')
- $(usev precompute-ecmult '--with-ecmult-window=24 --with-ecmult-gen-precision=8')
+ $(usev lowmem '--with-ecmult-window=4 --with-ecmult-gen-precision=2')
$(use_with valgrind)
)
if use asm; then
diff --git a/dev-libs/libsecp256k1/metadata.xml b/dev-libs/libsecp256k1/metadata.xml
index 3a2cdd782fc6..9a105e32f61a 100644
--- a/dev-libs/libsecp256k1/metadata.xml
+++ b/dev-libs/libsecp256k1/metadata.xml
@@ -15,8 +15,7 @@
<flag name="endomorphism">Enable endomorphism</flag>
<flag name="experimental">Allow experimental USE flags</flag>
<flag name="extrakeys">Enable extrakeys module</flag>
- <flag name="lowmem">Reduce runtime memory usage at the expense of performance (ecmult window size 2, gen precision 2)</flag>
- <flag name="precompute-ecmult">Use over 512 MB memory at runtime for better performance (ecmult window size 24, gen precision 8)</flag>
+ <flag name="lowmem">Reduce runtime memory usage at the expense of performance (ecmult window size 4, gen precision 2)</flag>
<flag name="recovery">Enable ECDSA pubkey recovery module</flag>
<flag name="schnorr">Enable Schnorr signature module</flag>
<flag name="test-openssl">Enable OpenSSL comparison tests</flag>