summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-09 02:13:31 +0000
committerSam James <sam@gentoo.org>2024-01-09 02:13:31 +0000
commit4b189630f89b1d486d709293152414c87f9cbc59 (patch)
tree851ef985a5647939ab6d019215022044d8626d4a /dev-libs/libisoburn
parentapp-shells/ksh: add 1.0.8 (diff)
downloadgentoo-4b189630f89b1d486d709293152414c87f9cbc59.tar.gz
gentoo-4b189630f89b1d486d709293152414c87f9cbc59.tar.bz2
gentoo-4b189630f89b1d486d709293152414c87f9cbc59.zip
dev-libs/libisoburn: autoreconf for newer libtool
Eli mentioned some odd behaviour with flag stripping at link-time with libisoburn and while investigating, I noticed that the libtool version used to make libisoburn's dist tarball is somewhat ancient (2.4.2 Debian-2.4.2-1.11). Use eautoreconf to refresh the version accordingly. I've also added some patches for -fdiagnostics-color and -frecord-gcc-switches to elt-patches but I didn't want to backport those to 2.4.2. 2.4.7 still needs them anyway. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libisoburn')
-rw-r--r--dev-libs/libisoburn/libisoburn-1.5.6-r1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/libisoburn/libisoburn-1.5.6-r1.ebuild b/dev-libs/libisoburn/libisoburn-1.5.6-r1.ebuild
new file mode 100644
index 000000000000..1ba1b08b9d8f
--- /dev/null
+++ b/dev-libs/libisoburn/libisoburn-1.5.6-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Creation/expansion of ISO-9660 filesystems on CD/DVD media supported by libburn"
+HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wiki/Libisoburn"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="acl debug external-filters external-filters-setuid frontend-optional
+ launch-frontend launch-frontend-setuid libedit readline static-libs xattr zlib"
+
+REQUIRED_USE="frontend-optional? ( || ( launch-frontend launch-frontend-setuid ) )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-libs/libburn-1.5.6
+ >=dev-libs/libisofs-1.5.6
+ readline? ( sys-libs/readline:0= )
+ !readline? ( libedit? ( dev-libs/libedit ) )
+ acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )
+ launch-frontend? ( dev-lang/tcl:0 dev-lang/tk:0 )
+ launch-frontend-setuid? ( dev-lang/tcl:0 dev-lang/tk:0 )
+ frontend-optional? ( dev-tcltk/bwidget )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ default
+
+ # Ancient libtool version in 1.5.6 at least (debian's 2.4.2-1.11)
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable readline libreadline) \
+ $(usex readline --disable-libedit $(use_enable libedit)) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ $(use_enable external-filters) \
+ $(use_enable external-filters-setuid) \
+ $(use_enable launch-frontend) \
+ $(use_enable launch-frontend-setuid) \
+ --disable-ldconfig-at-install \
+ --enable-pkg-check-modules \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.wiki,startup_file.txt}
+
+ docinto frontend
+ dodoc frontend/README-tcltk
+ docinto xorriso
+ dodoc xorriso/{changelog.txt,README_gnu_xorriso}
+
+ find "${D}" -name '*.la' -delete || die
+}