summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2016-02-25 18:46:27 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2016-02-25 18:46:43 +0100
commit7483dce1f1ea850bcb739d19a05cede84b9b2a33 (patch)
tree728846e4e5674500dda9069b8bf5d6563386d7ce /dev-libs/libgcrypt/libgcrypt-1.5.5.ebuild
parentapp-arch/p7zip: fixing bug 575622 (diff)
downloadgentoo-7483dce1f1ea850bcb739d19a05cede84b9b2a33.tar.gz
gentoo-7483dce1f1ea850bcb739d19a05cede84b9b2a33.tar.bz2
gentoo-7483dce1f1ea850bcb739d19a05cede84b9b2a33.zip
dev-libs/libgcrypt: Version bump of 0/11 to 1.5.5
This is a security fix release for * Mitigate chosen cipher text attacks on ECDH with Weierstrass curves. [CVE-2015-7511] (already backported to 1.5.4-r2) * Use ciphertext blinding for Elgamal decryption. [CVE-2014-3591] the libgcrypt 1.5 branch is EOL for security fixes YE2016 Gentoo-Bug: 541564 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.5.5.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.5.5.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.5.5.ebuild b/dev-libs/libgcrypt/libgcrypt-1.5.5.ebuild
new file mode 100644
index 000000000000..1c0a9518da1a
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.5.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-multilib
+
+DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0/11" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgpg-error-1.12[${MULTILIB_USEDEP}]
+ !dev-libs/libgcrypt:11
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
+ )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-uscore.patch
+ "${FILESDIR}"/${PN}-multilib-syspath.patch
+ "${FILESDIR}"/${PN}-1.5.4-clang-arm.patch
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/libgcrypt-config
+)
+
+src_configure() {
+ local myeconfargs=(
+ --disable-padlock-support # bug 201917
+ --disable-dependency-tracking
+ --enable-noexecstack
+ --disable-O-flag-munging
+ $(use_enable static-libs static)
+
+ # disabled due to various applications requiring privileges
+ # after libgcrypt drops them (bug #468616)
+ --without-capabilities
+
+ # http://trac.videolan.org/vlc/ticket/620
+ # causes bus-errors on sparc64-solaris
+ $([[ ${CHOST} == *86*-darwin* ]] && echo "--disable-asm")
+ $([[ ${CHOST} == sparcv9-*-solaris* ]] && echo "--disable-asm")
+ )
+ autotools-multilib_src_configure
+}