summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-11-28 10:41:17 -0500
committerSam James <sam@gentoo.org>2023-11-28 16:33:56 +0000
commit0a9201bc3785436f43b1459e647b1af1b82426c9 (patch)
tree297d5b1cd9300a7ecfd299a5e358d72ebbe052d5 /dev-libs/libcbor
parentx11-themes/gentoo-artwork: Fix fperms and rm failures (diff)
downloadgentoo-0a9201bc3785436f43b1459e647b1af1b82426c9.tar.gz
gentoo-0a9201bc3785436f43b1459e647b1af1b82426c9.tar.bz2
gentoo-0a9201bc3785436f43b1459e647b1af1b82426c9.zip
dev-libs/libcbor: remove useless USE flag that is a no-op
The current ebuild logs a warning: ``` CMake Warning at CMakeLists.txt:22 (message): CBOR_CUSTOM_ALLOC has been deprecated. Custom allocators are now enabled by default.The flag is a no-op and will be removed in the next version. Please remove CBOR_CUSTOM_ALLOC from your build configuation. ``` The USE flag only controls a cmake feature flag, but that feature flag is completely ignored and the resulting package is identical. Upstream commit: https://github.com/PJK/libcbor/commit/c03d88e02fe6f0a16389f6067b15dc3ed1b43401 Remove the USE flag. No revbump needed, the resulting package is the same either way, but people may feel free to rebuild on changed-USE anyway. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34026 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libcbor')
-rw-r--r--dev-libs/libcbor/libcbor-0.10.2.ebuild3
-rw-r--r--dev-libs/libcbor/metadata.xml3
2 files changed, 1 insertions, 5 deletions
diff --git a/dev-libs/libcbor/libcbor-0.10.2.ebuild b/dev-libs/libcbor/libcbor-0.10.2.ebuild
index 75b5ed188e33..83c83a5ed6ba 100644
--- a/dev-libs/libcbor/libcbor-0.10.2.ebuild
+++ b/dev-libs/libcbor/libcbor-0.10.2.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/PJK/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+custom-alloc doc test"
+IUSE="doc test"
BDEPEND="
doc? (
@@ -42,7 +42,6 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_BUILD_TYPE=Release
- -DCBOR_CUSTOM_ALLOC=$(usex custom-alloc 'ON' 'OFF')
-DWITH_TESTS=$(usex test 'ON' 'OFF')
)
diff --git a/dev-libs/libcbor/metadata.xml b/dev-libs/libcbor/metadata.xml
index 0b931e44104b..8ce035a8ef63 100644
--- a/dev-libs/libcbor/metadata.xml
+++ b/dev-libs/libcbor/metadata.xml
@@ -5,9 +5,6 @@
<email>base-system@gentoo.org</email>
<name>Gentoo Base System</name>
</maintainer>
- <use>
- <flag name="custom-alloc">Custom, dynamically defined allocator support</flag>
- </use>
<upstream>
<remote-id type="github">pjk/libcbor</remote-id>
</upstream>