summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-11-13 00:27:13 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-13 01:29:56 +0100
commit8b341e9fa966f90def1ffb00d368182c3c2da055 (patch)
treec8fa0eb2fe9707ebde3395b7665e8f259941fa8c /dev-libs/libatasmart
parentgnome-base/gnome-shell: version bump 3.22.1 → 3.22.2 (diff)
downloadgentoo-8b341e9fa966f90def1ffb00d368182c3c2da055.tar.gz
gentoo-8b341e9fa966f90def1ffb00d368182c3c2da055.tar.bz2
gentoo-8b341e9fa966f90def1ffb00d368182c3c2da055.zip
dev-libs/libatasmart: fix dependency on udev
And switch to EAPI=6. Gentoo-Bug: 562750 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-libs/libatasmart')
-rw-r--r--dev-libs/libatasmart/libatasmart-0.19-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libatasmart/libatasmart-0.19-r2.ebuild b/dev-libs/libatasmart/libatasmart-0.19-r2.ebuild
new file mode 100644
index 000000000000..f232df3d8fb1
--- /dev/null
+++ b/dev-libs/libatasmart/libatasmart-0.19-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+PATCH_LEVEL=2
+
+DESCRIPTION="A small and lightweight parser library for ATA S.M.A.R.T. hard disks"
+HOMEPAGE="http://0pointer.de/blog/projects/being-smart.html"
+SRC_URI="http://0pointer.de/public/${P}.tar.xz
+ mirror://debian/pool/main/liba/${PN}/${PN}_${PV}-${PATCH_LEVEL}.debian.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libudev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # https://bugs.gentoo.org/470874
+ local d="${WORKDIR}"/debian/patches
+ sed -i -e '/#/d' \
+ -e "s|^|${d}/|" "${d}"/series || die
+ eapply $(<"${d}"/series)
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}