summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-04-02 17:45:48 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-08 15:31:13 +0300
commit9706f77761b57456105cb70475c1be4e24a349d4 (patch)
treea37fb66024f24e880bcf9f7a2edcf046ff2e2258 /dev-libs/imath
parentwww-client/chromium: dev channel bump to 102.0.4987.0 (diff)
downloadgentoo-9706f77761b57456105cb70475c1be4e24a349d4.tar.gz
gentoo-9706f77761b57456105cb70475c1be4e24a349d4.tar.bz2
gentoo-9706f77761b57456105cb70475c1be4e24a349d4.zip
dev-libs/imath: bump to 3.1.5
Closes: https://bugs.gentoo.org/836653 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/24870 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/imath')
-rw-r--r--dev-libs/imath/Manifest1
-rw-r--r--dev-libs/imath/imath-3.1.5.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/imath/Manifest b/dev-libs/imath/Manifest
index eee626f653da..1777a34a5898 100644
--- a/dev-libs/imath/Manifest
+++ b/dev-libs/imath/Manifest
@@ -1 +1,2 @@
DIST imath-3.1.4.tar.gz 572214 BLAKE2B 6d67f542256e44f9ba6f30ae7d22a37dbf3cd1e49992fb8b0e2264d51d47e9c2297940b3a484e1f59bd8b251e8ef42d81ae88282d0769c111b3cd84cd0a9354e SHA512 f9f7d8ec333e6383191543ee927dc40e870a6330225b01070bb93ad3d149c5e31bd5989d4dc52f3321490c1c5a7cab55582c6e42e34ab4ca5723170e7578e286
+DIST imath-3.1.5.tar.gz 570875 BLAKE2B f78c8278a3ecb40afaa291b74c50c2ce01a5cba594e690041a57cfd3a65f9fe0842a41d600906ed864df239c2753488dedca53bdfa65a90c13513111a8068ca4 SHA512 8344e42c75d8e4bb21facb837535f0c9e4a9489d9edebcc25d5d3c6063535f2bf54e4517d8fca3fedada248457aa07c9bd77d6e843a9d115278fc154de2cdc9d
diff --git a/dev-libs/imath/imath-3.1.5.ebuild b/dev-libs/imath/imath-3.1.5.ebuild
new file mode 100644
index 000000000000..9b40568f036e
--- /dev/null
+++ b/dev-libs/imath/imath-3.1.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+MY_PN="${PN^}"
+
+DESCRIPTION="Imath basic math package"
+HOMEPAGE="https://imath.readthedocs.io"
+SRC_URI="https://github.com/AcademySoftwareFoundation/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+# re-keywording needed for (according to ilmbase keywords): ~x64-macos ~x86-solaris
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="3/29"
+IUSE="doc large-stack python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+# blocker due to file collision #803347
+RDEPEND="
+ !dev-libs/imath:0
+ !media-libs/ilmbase
+ sys-libs/zlib
+ python? (
+ !dev-python/pyilmbase
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( $(python_gen_cond_dep 'dev-python/breathe[${PYTHON_USEDEP}]') )
+ python? ( ${PYTHON_DEPS} )
+"
+
+DOCS=( CHANGES.md CONTRIBUTORS.md README.md SECURITY.md docs/PortingGuide2-3.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCS=$(usex doc)
+ -DIMATH_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DIMATH_HALF_USE_LOOKUP_TABLE=ON
+ -DIMATH_INSTALL_PKG_CONFIG=ON
+ -DIMATH_USE_CLANG_TIDY=OFF
+ -DIMATH_USE_NOEXCEPT=ON
+ )
+ if use python; then
+ mycmakeargs+=(
+ -DBoost_NO_BOOST_CMAKE=OFF
+ -DPYTHON=ON
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ fi
+
+ cmake_src_configure
+}