summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-05 10:34:48 +0000
committerSam James <sam@gentoo.org>2024-03-05 10:35:50 +0000
commitbcd670c0de8c9f9a1f83c96142e49fda36131a0f (patch)
tree44a8c96910aad567944af0e80f97f4c7f70a93ae /dev-libs/elfutils
parentdev-lang/gnat-gpl: fix configure (diff)
downloadgentoo-bcd670c0de8c9f9a1f83c96142e49fda36131a0f.tar.gz
gentoo-bcd670c0de8c9f9a1f83c96142e49fda36131a0f.tar.bz2
gentoo-bcd670c0de8c9f9a1f83c96142e49fda36131a0f.zip
dev-libs/elfutils: cleanup musl patch for 0.191
Thanks to Mark Wieelard for the review of the patches and suggestions for cleaning up obsolete bits. He notes we still need a proper fix for FNM_EXTMATCH though. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/elfutils-0.191.ebuild2
-rw-r--r--dev-libs/elfutils/files/elfutils-0.191-musl-macros.patch14
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-libs/elfutils/elfutils-0.191.ebuild b/dev-libs/elfutils/elfutils-0.191.ebuild
index 797cf5e83eb1..2825aaf9a27c 100644
--- a/dev-libs/elfutils/elfutils-0.191.ebuild
+++ b/dev-libs/elfutils/elfutils-0.191.ebuild
@@ -50,7 +50,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.189-musl-aarch64-regs.patch
- "${FILESDIR}"/${PN}-0.189-musl-macros.patch
+ "${FILESDIR}"/${PN}-0.191-musl-macros.patch
)
src_prepare() {
diff --git a/dev-libs/elfutils/files/elfutils-0.191-musl-macros.patch b/dev-libs/elfutils/files/elfutils-0.191-musl-macros.patch
new file mode 100644
index 000000000000..6e0912c5ce9a
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.191-musl-macros.patch
@@ -0,0 +1,14 @@
+https://git.alpinelinux.org/aports/plain/main/elfutils/musl-macros.patch
+--- a/lib/system.h
++++ b/lib/system.h
+@@ -56,6 +56,10 @@ void error(int status, int errnum, const char *format, ...);
+ #error "err.h or error.h must be available"
+ #endif
+
++#if !defined(FNM_EXTMATCH)
++# define FNM_EXTMATCH 0
++#endif
++
+ /* error (EXIT_FAILURE, ...) should be noreturn but on some systems it
+ isn't. This may cause warnings about code that should not be reachable.
+ So have an explicit error_exit wrapper that is noreturn (because it