summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2021-06-15 08:05:14 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2021-06-15 20:25:35 +0200
commit18cc6f1f6b39478801e35b836a6f45381d7acb7c (patch)
tree0838f978214fab34238c630924e38145d564154f /dev-libs/cereal/cereal-1.3.0-r1.ebuild
parentapp-misc/tmuxp-1.8.1: Version bump (diff)
downloadgentoo-18cc6f1f6b39478801e35b836a6f45381d7acb7c.tar.gz
gentoo-18cc6f1f6b39478801e35b836a6f45381d7acb7c.tar.bz2
gentoo-18cc6f1f6b39478801e35b836a6f45381d7acb7c.zip
dev-libs/cereal: new maintainer
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-3.0.18, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/21246 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-libs/cereal/cereal-1.3.0-r1.ebuild')
-rw-r--r--dev-libs/cereal/cereal-1.3.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/cereal/cereal-1.3.0-r1.ebuild b/dev-libs/cereal/cereal-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..c14fc8b906f6
--- /dev/null
+++ b/dev-libs/cereal/cereal-1.3.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Header-only C++11 serialization library"
+HOMEPAGE="https://uscilab.github.io/cereal/"
+SRC_URI="https://github.com/USCiLab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/boost )"
+
+src_prepare() {
+ sed -i -e '/set(CMAKE_CXX_FLAGS "-Wall -g -Wextra -Wshadow -pedantic -Wold-style-cast ${CMAKE_CXX_FLAGS}")/d' CMakeLists.txt || die
+
+ if ! use doc ; then
+ sed -i -e '/add_subdirectory(doc/d' CMakeLists.txt || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJUST_INSTALL_CEREAL=$(usex !test)
+ -DWITH_WERROR=OFF
+ )
+ cmake_src_configure
+}