summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-28 23:05:33 +0100
committerSam James <sam@gentoo.org>2023-08-28 23:06:29 +0100
commit5f99dd3b27a460f89596ca147bb30877c186151c (patch)
tree8eaed669791e985aafc18856f8046617e8ab1777 /dev-lang
parentdev-vcs/git-machete: add 3.18.1 (diff)
downloadgentoo-5f99dd3b27a460f89596ca147bb30877c186151c.tar.gz
gentoo-5f99dd3b27a460f89596ca147bb30877c186151c.tar.bz2
gentoo-5f99dd3b27a460f89596ca147bb30877c186151c.zip
dev-lang/perl: fix segfault w/ cross + musl, filter LTO properly
Implicit function declarations need to burn. While at it, modernise filtering LTO. Closes: https://bugs.gentoo.org/913171 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/perl-5.36.1-r3.ebuild5
-rw-r--r--dev-lang/perl/perl-5.38.0-r1.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-lang/perl/perl-5.36.1-r3.ebuild b/dev-lang/perl/perl-5.36.1-r3.ebuild
index f63397626bfe..553ab9f76a38 100644
--- a/dev-lang/perl/perl-5.36.1-r3.ebuild
+++ b/dev-lang/perl/perl-5.36.1-r3.ebuild
@@ -533,7 +533,7 @@ src_configure() {
filter-flags "-malign-double"
# Generic LTO broken since 5.28, triggers EUMM failures
- filter-flags "-flto"
+ filter-lto
use sparc && myconf -Ud_longdbl
@@ -583,6 +583,9 @@ src_configure() {
# modifying 'optimize' prevents cross configure script from appending required flags
if tc-is-cross-compiler; then
append-cflags "-fwrapv"
+
+ # bug #913171
+ export HOSTCFLAGS="${CFLAGS_FOR_BUILD} -D_GNU_SOURCE"
fi
# bug #877659, bug #821577
diff --git a/dev-lang/perl/perl-5.38.0-r1.ebuild b/dev-lang/perl/perl-5.38.0-r1.ebuild
index 21774a38d7d8..5dfbb02418dd 100644
--- a/dev-lang/perl/perl-5.38.0-r1.ebuild
+++ b/dev-lang/perl/perl-5.38.0-r1.ebuild
@@ -533,7 +533,7 @@ src_configure() {
filter-flags "-malign-double"
# Generic LTO broken since 5.28, triggers EUMM failures
- filter-flags "-flto"
+ filter-lto
use sparc && myconf -Ud_longdbl
@@ -583,6 +583,9 @@ src_configure() {
# modifying 'optimize' prevents cross configure script from appending required flags
if tc-is-cross-compiler; then
append-cflags "-fwrapv"
+
+ # bug #913171
+ export HOSTCFLAGS="${CFLAGS_FOR_BUILD} -D_GNU_SOURCE"
fi
# bug #877659, bug #821577