summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 04:17:18 -0400
committerSam James <sam@gentoo.org>2024-03-17 08:42:04 +0000
commit418e0544c39c797803d3bf0bafcd11682c4b6935 (patch)
treef28327239b9bce87b053b62dee70c8588ba517ee /dev-lang/tcc
parentsci-libs/stellarsolver: filter LTO (diff)
downloadgentoo-418e0544c39c797803d3bf0bafcd11682c4b6935.tar.gz
gentoo-418e0544c39c797803d3bf0bafcd11682c4b6935.tar.bz2
gentoo-418e0544c39c797803d3bf0bafcd11682c4b6935.zip
dev-lang/tcc: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/866815 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/tcc')
-rw-r--r--dev-lang/tcc/tcc-0.9.27_p20211022.ebuild11
-rw-r--r--dev-lang/tcc/tcc-0.9.27_p20230223.ebuild11
-rw-r--r--dev-lang/tcc/tcc-9999.ebuild11
3 files changed, 27 insertions, 6 deletions
diff --git a/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild b/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild
index 9026c599b410..c26113ad0aff 100644
--- a/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild
+++ b/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_COMMIT="16456168430c9e185dd94b8215aa77d02bbb8a2c"
DESCRIPTION="A very small C compiler for ix86/amd64"
@@ -54,6 +54,13 @@ src_prepare() {
}
src_configure() {
+ # fails tests
+ # https://bugs.gentoo.org/866815
+ #
+ # Also distributes static libraries:
+ # https://bugs.gentoo.org/926120
+ filter-lto
+
local libc
use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
diff --git a/dev-lang/tcc/tcc-0.9.27_p20230223.ebuild b/dev-lang/tcc/tcc-0.9.27_p20230223.ebuild
index c2d9231863d2..700abda72d4c 100644
--- a/dev-lang/tcc/tcc-0.9.27_p20230223.ebuild
+++ b/dev-lang/tcc/tcc-0.9.27_p20230223.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_COMMIT="29ae3ed4d5b83eec43598d6cd7949bccb41c8083"
DESCRIPTION="A very small C compiler for ix86/amd64"
@@ -54,6 +54,13 @@ src_prepare() {
}
src_configure() {
+ # fails tests
+ # https://bugs.gentoo.org/866815
+ #
+ # Also distributes static libraries:
+ # https://bugs.gentoo.org/926120
+ filter-lto
+
local libc
use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
diff --git a/dev-lang/tcc/tcc-9999.ebuild b/dev-lang/tcc/tcc-9999.ebuild
index a6f9afd599ac..c9e9a83a18e4 100644
--- a/dev-lang/tcc/tcc-9999.ebuild
+++ b/dev-lang/tcc/tcc-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_COMMIT="16456168430c9e185dd94b8215aa77d02bbb8a2c"
DESCRIPTION="A very small C compiler for ix86/amd64"
@@ -54,6 +54,13 @@ src_prepare() {
}
src_configure() {
+ # fails tests
+ # https://bugs.gentoo.org/866815
+ #
+ # Also distributes static libraries:
+ # https://bugs.gentoo.org/926120
+ filter-lto
+
local libc
use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise