summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-07-29 21:05:44 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-07-30 20:49:13 -0400
commit2979db2c1d18a27e1de54621afb330debe4f7649 (patch)
treea9d30584480183ceb79e30e8811f230843847ca3 /dev-lang/php
parentdev-lang/php: disable USE=coverage and hide /usr/bin/php. (diff)
downloadgentoo-2979db2c1d18a27e1de54621afb330debe4f7649.tar.gz
gentoo-2979db2c1d18a27e1de54621afb330debe4f7649.tar.bz2
gentoo-2979db2c1d18a27e1de54621afb330debe4f7649.zip
dev-lang/php: new addpredict() for a rare corner case.
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-8.2.8-r1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-lang/php/php-8.2.8-r1.ebuild b/dev-lang/php/php-8.2.8-r1.ebuild
index af66d51134a2..506f0c099e6a 100644
--- a/dev-lang/php/php-8.2.8-r1.ebuild
+++ b/dev-lang/php/php-8.2.8-r1.ebuild
@@ -581,6 +581,17 @@ src_compile() {
addpredict /usr/share/snmp/mibs/.index #nowarn
addpredict /var/lib/net-snmp/mib_indexes #nowarn
+ if use oci8-instant-client && use kerberos && use imap && use phar; then
+ # A conspiracy takes place when the first three of these flags
+ # are set together, causing the newly-built "php" to open
+ # /dev/urandom with mode rw when it starts. That's not actually
+ # a problem... unless you also have USE=phar, which runs that
+ # "php" to build some phar thingy in src_compile(). Later in
+ # src_test(), portage (at least) sets "addpredict /" so the
+ # problem does not repeat.
+ addpredict /dev/urandom #nowarn
+ fi
+
local sapi
for sapi in ${SAPIS} ; do
use "${sapi}" && emake -C "${WORKDIR}/sapis-build/${sapi}"