summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-09-16 13:30:35 +0200
committerJeroen Roovers <jer@gentoo.org>2017-09-16 13:51:21 +0200
commitdb93ef750b474d3ab90723c45de20c67823eae11 (patch)
treedcb816d0793153b1776ddb45510dc3f5cc75b175 /dev-lang/mujs/files
parentnet-libs/rpcsvc-proto: Fix some file collisions (diff)
downloadgentoo-db93ef750b474d3ab90723c45de20c67823eae11.tar.gz
gentoo-db93ef750b474d3ab90723c45de20c67823eae11.tar.bz2
gentoo-db93ef750b474d3ab90723c45de20c67823eae11.zip
dev-lang/mujs: Version bump (bug #621820).
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-lang/mujs/files')
-rw-r--r--dev-lang/mujs/files/mujs-1.0.1-gentoo.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/mujs/files/mujs-1.0.1-gentoo.patch b/dev-lang/mujs/files/mujs-1.0.1-gentoo.patch
new file mode 100644
index 000000000000..c6c7977ac75d
--- /dev/null
+++ b/dev-lang/mujs/files/mujs-1.0.1-gentoo.patch
@@ -0,0 +1,37 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+
+ build ?= release
+
+-prefix ?= /usr/local
++prefix ?= /usr
+ bindir ?= $(prefix)/bin
+ incdir ?= $(prefix)/include
+ libdir ?= $(prefix)/lib
+@@ -11,7 +11,7 @@
+
+ # Compiler flags for various configurations:
+
+-CFLAGS := -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
++CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
+
+ ifeq "$(CC)" "clang"
+ CFLAGS += -Wunreachable-code
+@@ -22,16 +22,6 @@
+ LDFLAGS += -Wl,--gc-sections
+ endif
+
+-ifeq "$(build)" "debug"
+-CFLAGS += -g
+-else ifeq "$(build)" "sanitize"
+-CFLAGS += -pipe -g -fsanitize=address -fno-omit-frame-pointer
+-LDFLAGS += -fsanitize=address
+-else
+-CFLAGS += -Os
+-LDFLAGS += -Wl,-s
+-endif
+-
+ # You shouldn't need to edit anything below here.
+
+ OUT := build/$(build)