summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-07-13 13:38:51 -0400
committerSam James <sam@gentoo.org>2023-07-26 03:51:54 +0100
commit27c62fe574c16b0e6eaee5a207f093e9a7915680 (patch)
treee5d58ff19f5a9e45ede9467540eca11cb307c374 /dev-lang/mono
parentdev-vcs/git-lfs: Update the live ebuild (diff)
downloadgentoo-27c62fe574c16b0e6eaee5a207f093e9a7915680.tar.gz
gentoo-27c62fe574c16b0e6eaee5a207f093e9a7915680.tar.bz2
gentoo-27c62fe574c16b0e6eaee5a207f093e9a7915680.zip
dev-lang/mono: Filter LTO with LLD
Compilation fails with LLD and LTO with the following error: ld.lld: error: boringssl/crypto/bn/CMakeFiles/bn.dir/convert.c.o <inline asm>:1:7: invalid operand for instruction divq $-8446744073709551616 ^~~~~~~~~~~~~~~~~~~~~ ld.lld: error: boringssl/crypto/asn1/CMakeFiles/asn1.dir/a_object.c.o <inline asm>:1:7: invalid operand for instruction divq $-9223372036854775808 ^~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/31866 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/mono-6.12.0.122.ebuild4
-rw-r--r--dev-lang/mono/mono-6.12.0.182.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/mono/mono-6.12.0.122.ebuild b/dev-lang/mono/mono-6.12.0.122.ebuild
index c644193115d7..db863dba7181 100644
--- a/dev-lang/mono/mono-6.12.0.122.ebuild
+++ b/dev-lang/mono/mono-6.12.0.122.ebuild
@@ -4,7 +4,7 @@
EAPI=7
CHECKREQS_DISK_BUILD="4500M"
-inherit autotools check-reqs linux-info mono-env pax-utils multilib-minimal
+inherit autotools check-reqs flag-o-matic linux-info mono-env pax-utils multilib-minimal toolchain-funcs
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="https://mono-project.com"
@@ -85,6 +85,8 @@ src_prepare() {
}
multilib_src_configure() {
+ tc-ld-is-lld && filter-lto
+
local myeconfargs=(
$(use_with xen xen_opt)
--without-ikvm-native
diff --git a/dev-lang/mono/mono-6.12.0.182.ebuild b/dev-lang/mono/mono-6.12.0.182.ebuild
index 20444696ffda..6d4584e910e1 100644
--- a/dev-lang/mono/mono-6.12.0.182.ebuild
+++ b/dev-lang/mono/mono-6.12.0.182.ebuild
@@ -4,7 +4,7 @@
EAPI=7
CHECKREQS_DISK_BUILD="4500M"
-inherit autotools check-reqs linux-info mono-env pax-utils multilib-minimal
+inherit autotools check-reqs flag-o-matic linux-info mono-env pax-utils multilib-minimal toolchain-funcs
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="https://mono-project.com"
@@ -85,6 +85,8 @@ src_prepare() {
}
multilib_src_configure() {
+ tc-ld-is-lld && filter-lto
+
local myeconfargs=(
$(use_with xen xen_opt)
--without-ikvm-native