summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-04-25 07:25:13 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-25 15:00:36 +0200
commit783ae0271796ea45b8a369e09a7f6b17b1ae5919 (patch)
treecbbaaeae8f810217863936e60340d74675be8dbf /dev-lang/crystal
parentdev-cpp/gtest: Stabilize 1.13.0 x86, #904582 (diff)
downloadgentoo-783ae0271796ea45b8a369e09a7f6b17b1ae5919.tar.gz
gentoo-783ae0271796ea45b8a369e09a7f6b17b1ae5919.tar.bz2
gentoo-783ae0271796ea45b8a369e09a7f6b17b1ae5919.zip
dev-lang/crystal: remove unused patches
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/30742 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/crystal')
-rw-r--r--dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-sandbox.patch22
-rw-r--r--dev-lang/crystal/files/crystal-0.27.0-extra-spec-flags.patch11
2 files changed, 0 insertions, 33 deletions
diff --git a/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-sandbox.patch b/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-sandbox.patch
deleted file mode 100644
index cab165c39059..000000000000
--- a/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-sandbox.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/spec/std/file_spec.cr
-+++ b/spec/std/file_spec.cr
-@@ -1164,3 +1164,4 @@ describe "File" do
- # TODO: there is no file which is reliably unwritable on windows
-- pending_win32 "raises if file cannot be accessed" do
-+ # On linux(or sandbox?) it's "Permission denied", not "Operation not permitted"
-+ pending "raises if file cannot be accessed" do
- expect_raises Errno, "Operation not permitted" do
---- a/spec/std/process_spec.cr
-+++ b/spec/std/process_spec.cr
-@@ -135,3 +135,4 @@ describe Process do
- describe "environ" do
-- it "clears the environment" do
-+ #gentoo's sandbox keeps sandbox environment
-+ pending "clears the environment" do
- value = Process.run("env", clear_env: true) do |proc|
-@@ -142,3 +143,4 @@ describe Process do
-
-- it "sets an environment variable" do
-+ #gentoo's sandbox keeps sandbox environment
-+ pending "sets an environment variable" do
- env = {"FOO" => "bar"}
diff --git a/dev-lang/crystal/files/crystal-0.27.0-extra-spec-flags.patch b/dev-lang/crystal/files/crystal-0.27.0-extra-spec-flags.patch
deleted file mode 100644
index bd86c13a78a6..000000000000
--- a/dev-lang/crystal/files/crystal-0.27.0-extra-spec-flags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Allow injecting additional arguments to test suite.
-Useful to be able to run small subset of individual
-test suite:
-
- make spec EXTRA_SPEC_FLAGS='-e parse_set_cookie'
-
---- a/Makefile
-+++ b/Makefile
-@@ -31 +31 @@ override FLAGS += $(if $(release),--release )$(if $(stats),--stats )$(if $(progr
--SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )
-+SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )$(EXTRA_SPEC_FLAGS)