summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-10-16 10:12:52 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-10-20 13:18:21 +0200
commita5a83e6b764ed915e5b2dbacdf6b2cbb7c9b6bdd (patch)
treede29abe202210723c48e711b676f22144b51d4f7 /dev-java
parentdev-lang/ammonite-repl-bin: add 2.5.5 (diff)
downloadgentoo-a5a83e6b764ed915e5b2dbacdf6b2cbb7c9b6bdd.tar.gz
gentoo-a5a83e6b764ed915e5b2dbacdf6b2cbb7c9b6bdd.tar.bz2
gentoo-a5a83e6b764ed915e5b2dbacdf6b2cbb7c9b6bdd.zip
dev-java/commons-text: add 1.10.0 (CVE-2022-42889)
Bug: https://bugs.gentoo.org/877577 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/27802 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-text/Manifest1
-rw-r--r--dev-java/commons-text/commons-text-1.10.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/commons-text/Manifest b/dev-java/commons-text/Manifest
index e99bcc4b22d1..f6c68f728c95 100644
--- a/dev-java/commons-text/Manifest
+++ b/dev-java/commons-text/Manifest
@@ -1 +1,2 @@
+DIST commons-text-1.10.0-src.tar.gz 342224 BLAKE2B efed282c9fed7dae5766f7158136a4d7414ba0610e16a52fa2d12ee04e43960d47ec7c62f220c2ab881a13afa8a81cf85e453364e37c67550e15c314122ebf25 SHA512 6bf2dc7dda4429cb1b9ba3a4d383c1d9ffabd5ff35a0adc55216e7cf4c532e51b2b012c9b0f3ea859cd32aef75e05547d892301f34f304a0bfd27c39a28fe04f
DIST commons-text-1.9-sources.tar.gz 312764 BLAKE2B 44b628c418a910ff38b5a1fb3b4c9f14a1f9818afd12540f8c8cf8b1a99fd7abd365e704142bcec901e5e067b303ff44f9c992f8714eae68b94819780a270dd2 SHA512 53f993e79aaa6789d3388aa96b6b2a14cf646b27ff3774524390e511241a85288947cc929519eff61a8734578f25bdf3d9969d84da20c1a749b19d90a55da8ae
diff --git a/dev-java/commons-text/commons-text-1.10.0.ebuild b/dev-java/commons-text/commons-text-1.10.0.ebuild
new file mode 100644
index 000000000000..49f9e33ed28d
--- /dev/null
+++ b/dev-java/commons-text/commons-text-1.10.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache//commons/text/source/commons-text-1.10.0-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-text-1.10.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.apache.commons:commons-text:1.10.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache Commons Text is a library focused on algorithms working on strings"
+HOMEPAGE="https://commons.apache.org/proper/commons-text/"
+SRC_URI="mirror://apache//commons/text/source/commons-text-${PV}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# org.apache.commons:commons-lang3:3.12.0 -> >=dev-java/commons-lang-3.12.0:3.6
+
+CDEPEND="
+ dev-java/commons-lang:3.6
+"
+
+# Compile dependencies
+# POM: pom.xml
+# test? commons-io:commons-io:2.11.0 -> >=dev-java/commons-io-2.11.0:1
+# test? org.apache.commons:commons-rng-simple:1.4 -> !!!artifactId-not-found!!!
+# test? org.assertj:assertj-core:3.23.1 -> !!!suitable-mavenVersion-not-found!!!
+# test? org.graalvm.js:js:22.0.0.2 -> !!!groupId-not-found!!!
+# test? org.graalvm.js:js-scriptengine:22.0.0.2 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.9.1 -> !!!groupId-not-found!!!
+# test? org.mockito:mockito-inline:4.8.0 -> !!!artifactId-not-found!!!
+# test? org.openjdk.jmh:jmh-core:1.35 -> >=dev-java/jmh-core-1.35:0
+# test? org.openjdk.jmh:jmh-generator-annprocess:1.35 -> !!!artifactId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CDEPEND}
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CDEPEND}"
+
+DOCS=( CONTRIBUTING.md NOTICE.txt README.md RELEASE-NOTES.txt )
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_AUTOMATIC_MODULE_NAME="org.apache.commons.text"
+JAVA_ENCODING="ISO-8859-1"
+
+JAVA_GENTOO_CLASSPATH="commons-lang-3.6"
+JAVA_SRC_DIR="src/main/java"