summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-17 16:43:15 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-27 10:54:24 +0200
commita49039b788cb9a538ff4f8c88446b801d50fc03b (patch)
tree4139881cc6dc3037a883471a7f9d4b4a1dd269a4 /dev-java
parentx11-misc/qlipper: Move dev-qt/linguist-tools:5 to BDEPEND, EAPI-8 (diff)
downloadgentoo-a49039b788cb9a538ff4f8c88446b801d50fc03b.tar.gz
gentoo-a49039b788cb9a538ff4f8c88446b801d50fc03b.tar.bz2
gentoo-a49039b788cb9a538ff4f8c88446b801d50fc03b.zip
dev-java/angus-activation: java 11 for module-info
Bug: https://bugs.gentoo.org/858560 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/angus-activation/angus-activation-1.0.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/angus-activation/angus-activation-1.0.0-r1.ebuild b/dev-java/angus-activation/angus-activation-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..9349e1ca9b70
--- /dev/null
+++ b/dev-java/angus-activation/angus-activation-1.0.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/eclipse-ee4j/angus-activation/archive/refs/tags/1.0.0.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild angus-activation-1.0.0-r1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.eclipse.angus:angus-activation:1.0.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Provides the implementation of the Jakarta Activation Specification"
+HOMEPAGE="https://github.com/eclipse-ee4j/angus-activation"
+SRC_URI="https://github.com/eclipse-ee4j/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-java/jakarta-activation-api:2
+ >=virtual/jdk-11:*"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( ../{CONTRIBUTING,NOTICE,README}.md )
+
+S="${WORKDIR}/${P}/activation-registry"
+
+JAVA_CLASSPATH_EXTRA="jakarta-activation-api-2"
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"