summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-27 15:16:58 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-27 15:21:15 -0400
commit4456f4048fd742900e7d267cfa1128dae6ff5510 (patch)
treeb77c59807fcc34dc326d4d3c5a7a15ea8ffdcdef /dev-java
parentapp-containers/docker-cli: drop 27.0.3 (diff)
downloadgentoo-4456f4048fd742900e7d267cfa1128dae6ff5510.tar.gz
gentoo-4456f4048fd742900e7d267cfa1128dae6ff5510.tar.bz2
gentoo-4456f4048fd742900e7d267cfa1128dae6ff5510.zip
dev-java/openjdk: mark as LTO-unsafe
Temporarily disable the USE=lto support for the 21.x ebuild only, as that's the version it broke in. OpenJDK cannot get their act together, so their ticketing system is that you cannot report a bug unless you're a project member, and your alternative is to fill in a form on the Oracle website and they will analyze your submission and file a bug on your behalf at some point. Hopefully. This is not a ringing endorsement of OpenJDK as an *open* implementation of Java, but it is what it is... I can't currently provide a public ticket number but perhaps sometime in the future. Closes: https://bugs.gentoo.org/916735 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/openjdk/openjdk-21.0.4_p7.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-java/openjdk/openjdk-21.0.4_p7.ebuild b/dev-java/openjdk/openjdk-21.0.4_p7.ebuild
index 943ac23576da..2fe2a993eaea 100644
--- a/dev-java/openjdk/openjdk-21.0.4_p7.ebuild
+++ b/dev-java/openjdk/openjdk-21.0.4_p7.ebuild
@@ -48,7 +48,8 @@ LICENSE="GPL-2-with-classpath-exception"
SLOT="${MY_PV%%[.+]*}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="alsa big-endian cups debug doc examples headless-awt javafx +jbootstrap lto selinux source +system-bootstrap systemtap"
+# lto temporarily disabled due to https://bugs.gentoo.org/916735
+IUSE="alsa big-endian cups debug doc examples headless-awt javafx +jbootstrap selinux source +system-bootstrap systemtap"
REQUIRED_USE="
javafx? ( alsa !headless-awt )
@@ -225,7 +226,11 @@ src_configure() {
use riscv && myconf+=( --with-boot-jdk-jvmargs="-Djdk.lang.Process.launchMechanism=vfork" )
- use lto && myconf+=( --with-jvm-features=link-time-opt )
+ # Werror=odr
+ # https://bugs.gentoo.org/916735
+ #
+ # Disable it for now.
+ #use lto && myconf+=( --with-jvm-features=link-time-opt )
if use javafx; then
local zip="${EPREFIX}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"