summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jump
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jump')
-rw-r--r--dev-java/jump/Manifest1
-rw-r--r--dev-java/jump/files/0.5-test.patch14
-rw-r--r--dev-java/jump/jump-0.5.ebuild42
-rw-r--r--dev-java/jump/metadata.xml8
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-java/jump/Manifest b/dev-java/jump/Manifest
new file mode 100644
index 000000000000..2ad6c12d6444
--- /dev/null
+++ b/dev-java/jump/Manifest
@@ -0,0 +1 @@
+DIST jump-0.5.tar.gz 31266 SHA256 608c3ea156cca8ce6890f593467a8b5b41b257479a84178bff8b957ed56ddac0 SHA512 9772ea61e921c4342f0e25a951d74850b9dbdd2bde5de9fabad4d55ddb82b6d09debd478f92f3f8c02a05425244b7eaf12d7b3d7d2876263234bafa27783bba8 WHIRLPOOL 6f32af4aabe2964edc9a450c06d01d7f3d69873cf8d7988826941fa9838e841dd04ea584eca59dd3d1c4dec263f62762ad72a090324f411a63915acd1d8f3140
diff --git a/dev-java/jump/files/0.5-test.patch b/dev-java/jump/files/0.5-test.patch
new file mode 100644
index 000000000000..796d0d022dd0
--- /dev/null
+++ b/dev-java/jump/files/0.5-test.patch
@@ -0,0 +1,14 @@
+diff -Naur jump-0.5.vanilla/src/tests/org/znerd/math/tests/NumberCentralTests.java jump-0.5/src/tests/org/znerd/math/tests/NumberCentralTests.java
+--- jump-0.5.vanilla/src/tests/org/znerd/math/tests/NumberCentralTests.java 2007-10-10 00:27:47.000000000 +0200
++++ jump-0.5/src/tests/org/znerd/math/tests/NumberCentralTests.java 2007-10-10 00:28:38.000000000 +0200
+@@ -220,8 +220,8 @@
+ assertEquals(ONE_HALF, NumberCentral.valueOf( 0.5));
+ assertEquals(ONE, NumberCentral.valueOf( 1.0));
+ assertEquals(TWO, NumberCentral.valueOf( 2.0));
+- assertEquals(Double.MIN_VALUE, NumberCentral.valueOf(Double.MIN_VALUE).doubleValue(), 0.0);
+- assertEquals(Double.MIN_VALUE, NumberCentral.valueOf(Double.MAX_VALUE).doubleValue(), 0.0);
++ assertEquals(Double.MIN_VALUE, NumberCentral.valueOf(Double.MIN_VALUE).doubleValue(), Double.MIN_VALUE);
++ assertEquals(Double.MAX_VALUE, NumberCentral.valueOf(Double.MAX_VALUE).doubleValue(), Double.MIN_VALUE);
+ }
+
+ /**
diff --git a/dev-java/jump/jump-0.5.ebuild b/dev-java/jump/jump-0.5.ebuild
new file mode 100644
index 000000000000..a9283a86a71d
--- /dev/null
+++ b/dev-java/jump/jump-0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc examples source test"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JUMP Ultimate Math Package (JUMP) is a Java-based extensible high-precision math package"
+SRC_URI="mirror://sourceforge/${PN}-math/${P}.tar.gz"
+HOMEPAGE="http://jump-math.sourceforge.net/"
+KEYWORDS="amd64 ~ppc x86"
+LICENSE="BSD"
+SLOT="0"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit =dev-java/junit-3* )"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/0.5-test.patch"
+
+ sed -i 's:${java.home}/src::' -i build.xml || die
+ java-ant_rewrite-classpath
+}
+
+EANT_BUILD_TARGET="jar"
+EANT_DOC_TARGET="apidocs"
+
+src_test() {
+ local cp="$(java-pkg_getjars junit)"
+ ANT_TASKS="ant-junit" eant do-tests -Dgentoo.classpath="${cp}"
+}
+
+src_install() {
+ java-pkg_dojar build/${PN}.jar
+
+ use doc && java-pkg_dojavadoc build/apidocs
+ use examples && java-pkg_doexamples src/examples
+ use source && java-pkg_dosrc src/main/org
+}
diff --git a/dev-java/jump/metadata.xml b/dev-java/jump/metadata.xml
new file mode 100644
index 000000000000..c6c19da3cdd6
--- /dev/null
+++ b/dev-java/jump/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jump-math</remote-id>
+ </upstream>
+</pkgmetadata>