summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-20 01:01:20 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-20 01:12:16 +0000
commit1e0e3ad3ff772e0164e1a3dc2496724ef6554da4 (patch)
tree19ff24e6d543bb46faf77706ca0d147c7f930399 /dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild
parentdev-java/hoteqn: EAPI 5 bump. Switch to java-pkg-simple. (diff)
downloadgentoo-1e0e3ad3ff772e0164e1a3dc2496724ef6554da4.tar.gz
gentoo-1e0e3ad3ff772e0164e1a3dc2496724ef6554da4.tar.bz2
gentoo-1e0e3ad3ff772e0164e1a3dc2496724ef6554da4.zip
dev-java/jexcelapi: Switch to java-pkg-simple. Unbundle log4j.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild')
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild b/dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild
new file mode 100644
index 000000000000..9fd07137f28d
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-java/log4j:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ app-arch/unzip
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${PN}"
+
+JAVA_ENCODING="ISO-8859-1"
+JAVA_SRC_DIR="src"
+JAVA_GENTOO_CLASSPATH="log4j"
+
+JAVA_RM_FILES=(
+ src/common/log/Log4jLoggerName.java
+ src/common/log/SimpleLoggerName.java
+)
+
+java_prepare() {
+ java-pkg_clean
+}