summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-05-08 23:44:22 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-05-09 13:07:04 +0200
commit347500e184776a92004e54f4df6196a94f68f652 (patch)
treee548ed1b6aa568dffd1ab089a0e7208e83790307 /dev-java/guice
parentdev-java/j2objc-annotations: add 3.0.0 - drop restriction on jdk:1.8 (diff)
downloadgentoo-347500e184776a92004e54f4df6196a94f68f652.tar.gz
gentoo-347500e184776a92004e54f4df6196a94f68f652.tar.bz2
gentoo-347500e184776a92004e54f4df6196a94f68f652.zip
dev-java/guice: adjust ${CDEPEND} -> ${CP_DEPEND}
Also some code cleanup Closes: https://bugs.gentoo.org/931594 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/36614 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/guice')
-rw-r--r--dev-java/guice/guice-5.1.0-r1.ebuild (renamed from dev-java/guice/guice-5.1.0.ebuild)34
1 files changed, 5 insertions, 29 deletions
diff --git a/dev-java/guice/guice-5.1.0.ebuild b/dev-java/guice/guice-5.1.0-r1.ebuild
index e1ee08998250..4f2610fff44c 100644
--- a/dev-java/guice/guice-5.1.0.ebuild
+++ b/dev-java/guice/guice-5.1.0-r1.ebuild
@@ -1,9 +1,6 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom core/pom.xml --download-uri https://github.com/google/guava/archive/v30.1.1.tar.gz --slot 5 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x866" --ebuild guice-5.1.0.ebuild
-
EAPI=8
JAVA_PKG_IUSE="doc source test"
@@ -15,6 +12,7 @@ inherit java-pkg-2 java-pkg-simple
DESCRIPTION="Guice is a lightweight dependency injection framework for Java 6 and above"
HOMEPAGE="https://github.com/google/guice"
SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}"
LICENSE="Apache-2.0"
SLOT="4"
@@ -23,32 +21,17 @@ KEYWORDS="amd64 ~arm arm64 ppc64 x86"
# Most of the test dependencies are missing in Gentoo.
RESTRICT="test"
-# Common dependencies
-# POM: core/pom.xml
-# aopalliance:aopalliance:1.0 -> >=dev-java/aopalliance-1.0:1
-# com.google.guava:guava:30.1-jre -> >=dev-java/guava-30.1.1:0
-# javax.inject:javax.inject:1 -> >=dev-java/javax-inject-1:0
-# org.ow2.asm:asm:9.2 -> >=dev-java/asm-9.2:9
-
CP_DEPEND="
dev-java/aopalliance:1
dev-java/asm:9
+ dev-java/error-prone-annotations:0
dev-java/guava:0
dev-java/javax-inject:0
"
-# Compile dependencies
-# POM: core/pom.xml
-# test? biz.aQute:bnd:0.0.384 -> !!!groupId-not-found!!!
-# test? com.google.guava:guava-testlib:30.1-jre -> >=dev-java/guava-testlib-30.1.1:0
-# test? com.google.truth:truth:0.45 -> !!!groupId-not-found!!!
-# test? javax.inject:javax.inject-tck:1 -> !!!artifactId-not-found!!!
-# test? junit:junit:4.13 -> >=dev-java/junit-4.13.2:4
-# test? org.apache.felix:org.apache.felix.framework:3.0.5 -> !!!groupId-not-found!!!
-
DEPEND="
>=virtual/jdk-1.8:*
- ${CDEPEND}
+ ${CP_DEPEND}
test? (
dev-java/guava-testlib:0
)
@@ -60,8 +43,6 @@ RDEPEND="
DOCS=( {COPYING,{CONTRIBUTING,README}.md} )
-S="${WORKDIR}/${P}"
-
JAVA_SRC_DIR=( "core/src" )
JAVA_RESOURCE_DIRS=( "core/res" )
@@ -70,12 +51,7 @@ JAVA_TEST_SRC_DIR=( "core/test" )
JAVA_TEST_RESOURCE_DIRS=( "core/test" )
src_prepare() {
- default
+ java-pkg-2_src_prepare
mkdir -p "core/res/com/google/inject/" || die
cp core/{src,res}/com/google/inject/BUILD || die
}
-
-src_install() {
- default # https://bugs.gentoo.org/789582
- java-pkg-simple_src_install
-}