summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-10-30 14:19:37 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-12-03 10:05:16 +0100
commitb0ecba66c1ea1461a7a4667dec8c23015f818baf (patch)
tree1afd69ac85d4e3496d91e167d89bf33fe54a42af /dev-java/commons-collections
parentdev-java/commons-collections: add github upstream metadata (diff)
downloadgentoo-b0ecba66c1ea1461a7a4667dec8c23015f818baf.tar.gz
gentoo-b0ecba66c1ea1461a7a4667dec8c23015f818baf.tar.bz2
gentoo-b0ecba66c1ea1461a7a4667dec8c23015f818baf.zip
dev-java/commons-collections: slot 0, max jdk 17
switches from java-ant-2.eclass to java-pkg-simple.eclass Bug: https://bugs.gentoo.org/916445 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/commons-collections-3.2.2-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/commons-collections/commons-collections-3.2.2-r2.ebuild b/dev-java/commons-collections/commons-collections-3.2.2-r2.ebuild
new file mode 100644
index 000000000000..d5c0110ad865
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-3.2.2-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-collections:commons-collections:${PV}"
+JAVA_TESTING_FRAMEWORKS="junit"
+
+inherit java-pkg-2 java-pkg-simple verify-sig
+
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="https://commons.apache.org/collections/"
+SRC_URI="https://archive.apache.org/dist/commons/collections/source/${P}-src.tar.gz
+ verify-sig? ( https://archive.apache.org/dist/commons/collections/source/${P}-src.tar.gz.asc )"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/commons.apache.org.asc"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-apache-commons )"
+# broken with jdk:21 - https://bugs.gentoo.org/916445
+DEPEND="
+ <=virtual/jdk-17:*
+ test? ( dev-java/junit:0 )
+"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {NOTICE,README,RELEASE-NOTES}.txt )
+HTML_DOCS=( {DEVELOPERS-GUIDE,PROPOSAL}.html )
+
+PATCHES=( "${FILESDIR}/${P}-fixes.patch" )
+
+JAVA_SRC_DIR="src/java"
+JAVA_TEST_GENTOO_CLASSPATH="junit"
+JAVA_TEST_SRC_DIR="src/test"
+
+src_prepare() {
+ default #780585
+ java-pkg-2_src_prepare
+}
+
+src_test() {
+ if [[ "${ARCH}" = "ppc" ]]; then
+ einfo "tests are disabled on ppc"
+ else
+ java-pkg-simple_src_test
+ fi
+}