summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-17 12:42:16 +0100
committerSam James <sam@gentoo.org>2021-05-17 21:09:19 +0000
commitf313d37cc5e8fd4d60b0bc10443ea018728f9e3c (patch)
treec4919acc809a33886b7deeea57cf6782843d9346 /dev-java/classmate/classmate-0.9.0-r1.ebuild
parentprofiles: base: Drop obsolete dev-python/pep8 p.use.mask entry (diff)
downloadgentoo-f313d37cc5e8fd4d60b0bc10443ea018728f9e3c.tar.gz
gentoo-f313d37cc5e8fd4d60b0bc10443ea018728f9e3c.tar.bz2
gentoo-f313d37cc5e8fd4d60b0bc10443ea018728f9e3c.zip
dev-java/classmate: Remove last-rited pkg
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/classmate/classmate-0.9.0-r1.ebuild')
-rw-r--r--dev-java/classmate/classmate-0.9.0-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-java/classmate/classmate-0.9.0-r1.ebuild b/dev-java/classmate/classmate-0.9.0-r1.ebuild
deleted file mode 100644
index f6deb6b4e717..000000000000
--- a/dev-java/classmate/classmate-0.9.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-pkg-simple vcs-snapshot
-
-DESCRIPTION="Zero-dependency Java library for accurately introspecting type information"
-HOMEPAGE="https://github.com/cowtowncoder/java-classmate/"
-SRC_URI="https://github.com/cowtowncoder/java-classmate/archive/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.6"
-DEPEND=">=virtual/jdk-1.6
- test? ( dev-java/junit:4 )"
-
-S="${WORKDIR}/${P}"
-
-JAVA_SRC_DIR="src/main/java"
-
-# This one test is buggy.
-JAVA_RM_FILES=(
- src/test/java/com/fasterxml/classmate/AnnotationsTest.java
-)
-
-java_prepare() {
- rm pom.xml || die
-}
-
-src_test() {
- testcp="${S}/${PN}.jar:$(java-pkg_getjars junit-4):target/tests"
-
- mkdir target/tests || die
- ejavac -cp "${testcp}" -d target/tests $(find src/test/java -name "*.java")
-
- tests=$(find target/tests -name "*Test.class" -not -name "BaseTest.class" \
- | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
- | grep -vP '\$');
- ejunit4 -cp "${testcp}" ${tests}
-}