summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:08 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:13 +0100
commit7cb3afdf3503b6686e088bbdf6c3c21bf9a6881f (patch)
tree77c00cb141fad7f29538acc6653a890eb39838b5 /dev-haskell/text-icu
parentdev-haskell/text-conversions: add 0.3.1.1 (diff)
downloadgentoo-7cb3afdf3503b6686e088bbdf6c3c21bf9a6881f.tar.gz
gentoo-7cb3afdf3503b6686e088bbdf6c3c21bf9a6881f.tar.bz2
gentoo-7cb3afdf3503b6686e088bbdf6c3c21bf9a6881f.zip
dev-haskell/text-icu: add 0.8.0.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/text-icu')
-rw-r--r--dev-haskell/text-icu/Manifest1
-rw-r--r--dev-haskell/text-icu/metadata.xml31
-rw-r--r--dev-haskell/text-icu/text-icu-0.8.0.2.ebuild36
3 files changed, 39 insertions, 29 deletions
diff --git a/dev-haskell/text-icu/Manifest b/dev-haskell/text-icu/Manifest
index 8f7010cfbe64..20e70edf5b7f 100644
--- a/dev-haskell/text-icu/Manifest
+++ b/dev-haskell/text-icu/Manifest
@@ -1 +1,2 @@
DIST text-icu-0.7.1.0.tar.gz 52490 BLAKE2B fb66502b0a18d8d2a0f1dcb2240e9c939b04b157acac31b62fbe65a6d5edd6244a4713d712e6b78dc54451b52d3e78d9cd8bc803e7bddb319fa8ed016c162123 SHA512 807a1385b7601edcfa6142a8e107df1b3c2820974218e2bafadb8a42eda3b68a0a16d222d75120b422e5ca9f4cd4f52f39d2b7938a541692ed4d633d5750089a
+DIST text-icu-0.8.0.2.tar.gz 85213 BLAKE2B 68fe194da996b33de5c8ea3b3bb3daec1181a35a1f528328fdcfd38ca89857df2966b38d05b8c0aaf070e081040678a521a6f591c0af36a78b716cb19f4a08f7 SHA512 c70b014200678b19d763347dce021970062cdbee024c93bfd09b084615f1734283d0d6eb17db64901a83e9a293c79ff8fbf7d45e8a67eb812ce5bcc85b72b9e6
diff --git a/dev-haskell/text-icu/metadata.xml b/dev-haskell/text-icu/metadata.xml
index cf90d36efbec..33f4332f7eab 100644
--- a/dev-haskell/text-icu/metadata.xml
+++ b/dev-haskell/text-icu/metadata.xml
@@ -5,35 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Haskell bindings to the International Components for Unicode (ICU)
- libraries. These libraries provide robust and full-featured Unicode
- services on a wide variety of platforms.
-
- Features include:
-
- * Both pure and impure bindings, to allow for fine control over efficiency
- and ease of use.
-
- * Breaking of strings on character, word, sentence, and line boundaries.
-
- * Access to the Unicode Character Database (UCD) of character metadata.
-
- * String collation functions, for locales where the conventions for
- lexicographic ordering differ from the simple numeric ordering of
- character codes.
-
- * Character set conversion functions, allowing conversion between
- Unicode and over 220 character encodings.
-
- * Unicode normalization. (When implementations keep strings in a
- normalized form, they can be assured that equivalent strings have a
- unique binary representation.)
-
- * Regular expression search and replace.
- </longdescription>
<upstream>
- <remote-id type="github">bos/text-icu</remote-id>
- <remote-id type="bitbucket">bos/text-icu</remote-id>
+ <remote-id type="hackage">text-icu</remote-id>
+ <remote-id type="github">haskell/text-icu</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/text-icu/text-icu-0.8.0.2.ebuild b/dev-haskell/text-icu/text-icu-0.8.0.2.ebuild
new file mode 100644
index 000000000000..502b75b161bb
--- /dev/null
+++ b/dev-haskell/text-icu/text-icu-0.8.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to the ICU library"
+HOMEPAGE="https://github.com/haskell/text-icu"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RESTRICT=test # QuickCheck occasionally finds counterexamples
+# and fails to build: Duplicate instance declarations: instance NFData Ordering
+
+RDEPEND=">=dev-haskell/text-0.9.1.0:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ dev-libs/icu
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+# test? ( >=dev-haskell/hunit-1.2
+# >=dev-haskell/quickcheck-2.4
+# dev-haskell/random
+# >=dev-haskell/test-framework-0.4
+# >=dev-haskell/test-framework-hunit-0.2
+# >=dev-haskell/test-framework-quickcheck2-0.2
+# dev-haskell/text )
+# "