summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:19:44 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commita722f52d6929d35e602aae2671ea762a14ca15ed (patch)
tree58ff81adc7e842b0a583be40658765dbce76eb4d /dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2.ebuild
parentdev-haskell/terminal-size: bump up to 0.3.2.1 (diff)
downloadgentoo-a722f52d6929d35e602aae2671ea762a14ca15ed.tar.gz
gentoo-a722f52d6929d35e602aae2671ea762a14ca15ed.tar.bz2
gentoo-a722f52d6929d35e602aae2671ea762a14ca15ed.zip
dev-haskell/test-framework-hunit: bump up to 0.3.0.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2.ebuild')
-rw-r--r--dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2.ebuild b/dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2.ebuild
new file mode 100644
index 000000000000..cef108fa26d0
--- /dev/null
+++ b/dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: +base4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="HUnit support for the test-framework package"
+HOMEPAGE="https://batterseapower.github.io/test-framework/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?] <dev-haskell/extensible-exceptions-0.2.0:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-1.4:=[profile?]
+ >=dev-haskell/test-framework-0.2.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=base4
+}