summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:02 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:57 +0100
commit9fb48c07294683f1a6fba3787278aa663d25729a (patch)
tree5d8f15e8bbf730e94f6ca17cc3bd9ddda4f38038 /dev-haskell/parsec1
parentdev-haskell/optparse-applicative: add 0.18.1.0 (diff)
downloadgentoo-9fb48c07294683f1a6fba3787278aa663d25729a.tar.gz
gentoo-9fb48c07294683f1a6fba3787278aa663d25729a.tar.bz2
gentoo-9fb48c07294683f1a6fba3787278aa663d25729a.zip
dev-haskell/parsec1: add 1.0.0.8
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/parsec1')
-rw-r--r--dev-haskell/parsec1/Manifest1
-rw-r--r--dev-haskell/parsec1/metadata.xml26
-rw-r--r--dev-haskell/parsec1/parsec1-1.0.0.8.ebuild23
3 files changed, 24 insertions, 26 deletions
diff --git a/dev-haskell/parsec1/Manifest b/dev-haskell/parsec1/Manifest
index 998a1bd4ede2..fc973842a4cb 100644
--- a/dev-haskell/parsec1/Manifest
+++ b/dev-haskell/parsec1/Manifest
@@ -1 +1,2 @@
DIST parsec1-1.0.0.7.tar.gz 13440 BLAKE2B c445585d3db87a1abf7ea0a3157145241396ced3202c70927d355e76ad7b40f802ec0701efdc4e4dcbcdd024d6837d8eae118513acaedd44b77634befd89f7d7 SHA512 6ce75332064f811b105091d6adbdc2d0cfe571ec04674cf7b8f79d50df5b6d81f4a32a703151c09dfd9022b6df0929ceafc7f7451b4dff7bbc79382dc5ac743c
+DIST parsec1-1.0.0.8.tar.gz 12933 BLAKE2B 414077432a74a719754c634f16815bfd9c78892067f275d0dbdeed929950c88a2e87c56ffd9e2c07560d92ed6640d8778d0b4ff83a8d73313f7fb6276d7d7550 SHA512 fa7185ff5392130c5fd538f93a613046e667bd95596951dd04340d818f8e6412e5c254c10517bd8decd1547d547da2b920acfb32fcc90980627bb0214b9941b0
diff --git a/dev-haskell/parsec1/metadata.xml b/dev-haskell/parsec1/metadata.xml
index 927852cac2d5..937381521944 100644
--- a/dev-haskell/parsec1/metadata.xml
+++ b/dev-haskell/parsec1/metadata.xml
@@ -5,30 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Parsec is designed from scratch as an industrial-strength parser
- library. It is simple, safe, well documented (on the package
- homepage), has extensive libraries and good error messages,
- and is also fast.
-
- This package is the core haskell98 part of the parsec2
- package, intended to preserve its simplicity and portability.
-
- Note, that the module names overlap with those of parsec from the Haskell
- Platform, therefore I do not recommend to unconditionally use parsec1 (or
- parsec2 and parsec3) as dependency in cabal files of packages for hackage.
- But you may want to develop your code using these limited and portable
- parsec1 functions and finally change the dependency from parsec1 to parsec
- in order to avoid module ambiguities for users just installing your package.
- Your own module ambiguities are best avoided by hiding packages.
-
- This version only differs from the pervious one by improved error messages
- for try (positions are not reset), tokens and thus string (longer
- unexpected strings are now reported to match the error position).
- The notFollowedBy-parser was generalized (as in parsec-3) so
- characters in messages are now shown in single instead of double
- quotes.
- Also (as since parsec-3.1.2) lookAhead no longer consumes tokens on success
- (so that the many-parser can detect this).
- </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/parsec1/parsec1-1.0.0.8.ebuild b/dev-haskell/parsec1/parsec1-1.0.0.8.ebuild
new file mode 100644
index 000000000000..e6327d9cab98
--- /dev/null
+++ b/dev-haskell/parsec1/parsec1-1.0.0.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Portable monadic parser combinators"
+HOMEPAGE="https://hackage.haskell.org/package/parsec1"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"