summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-14 19:33:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-14 19:39:44 +0000
commite36cd84d232a2b23a2bb7f993f06bec13f09d2b6 (patch)
tree96ea0b41a02c0d574cbcfa2f858b4adb6f9028c3 /dev-haskell/monad-par
parentdev-haskell/monadplus: bump up to 1.4.2-r1 (diff)
downloadgentoo-e36cd84d232a2b23a2bb7f993f06bec13f09d2b6.tar.gz
gentoo-e36cd84d232a2b23a2bb7f993f06bec13f09d2b6.tar.bz2
gentoo-e36cd84d232a2b23a2bb7f993f06bec13f09d2b6.zip
dev-haskell/monad-par: bump up to 0.3.5
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/monad-par')
-rw-r--r--dev-haskell/monad-par/Manifest1
-rw-r--r--dev-haskell/monad-par/monad-par-0.3.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/monad-par/Manifest b/dev-haskell/monad-par/Manifest
index 2497240913d9..68747cde1814 100644
--- a/dev-haskell/monad-par/Manifest
+++ b/dev-haskell/monad-par/Manifest
@@ -1,2 +1,3 @@
DIST monad-par-0.3.4.7.tar.gz 30411 BLAKE2B b7ed0e6e10c992fb3c2cb75813f180b6124215902aa5decd66d96ada7fc14623a3a1b2c4cfe9cf863087643091ebe24da3099e4f4652a4d1fce17f5cd71eb2f0 SHA512 eb9bd155589e9e7aea51e8b79f7fca20cfc8ac0dabf9c475fbbb312139311d567e1f19779247fd331c8242c93c9cefc1d52fca599c6444f90194d2a193182772
DIST monad-par-0.3.4.8.tar.gz 30583 BLAKE2B c0d31959d7f1b50eb763810e4199b2a7a27b8ca202f078d23b6ae5c62f94cadbf5f7169959e577d59d0bb85cfe450af06e71b85410573ec50f37d9c36b458411 SHA512 6d2f6f571a3eef804e69ca892cf865bb169863d4fa97cad94cfb740925861b827fef14595c2edf235a8a60babdb854eecb87ff09bb798a6912edb7c3c6fe7027
+DIST monad-par-0.3.5.tar.gz 31675 BLAKE2B 02299d3a6813618e43d2786bb6963d1fda74fe50f84f2ada86890e87b38803ef1a1042dddc83c8e813cd9b1461710991a37900ee059222ecf65dc7706ed99450 SHA512 0843753f5a1465f46ade4c60b0707a07e996f12b13f8248e4c3dc6eeb5f0b8b4a321acb4dff685d17ef52d36db32cec5564e6492f7027c9d93f03c5780895b9c
diff --git a/dev-haskell/monad-par/monad-par-0.3.5.ebuild b/dev-haskell/monad-par/monad-par-0.3.5.ebuild
new file mode 100644
index 000000000000..a82a39857566
--- /dev/null
+++ b/dev-haskell/monad-par/monad-par-0.3.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+#hackport: flags: -newgeneric
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A library for parallel programming based on a monad"
+HOMEPAGE="https://github.com/simonmar/monad-par"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="chaselev"
+
+RDEPEND=">=dev-haskell/abstract-deque-0.1.4:=[profile?]
+ dev-haskell/abstract-par:=[profile?]
+ >=dev-haskell/monad-par-extras-0.3:=[profile?]
+ >=dev-haskell/mtl-2.0.1.0:=[profile?]
+ >=dev-haskell/mwc-random-0.11:=[profile?]
+ >=dev-haskell/parallel-3.1:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ chaselev? ( dev-haskell/chaselev-deque:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.3
+ dev-haskell/test-framework-th )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag chaselev chaselev) \
+ --flag=-newgeneric
+}