summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:12 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:47 +0100
commit43bd73dae5b55bff1223990912da2928a95b0734 (patch)
treed0f79165a572cd558989050acf5ebd99598cdf77 /dev-haskell/http
parentdev-haskell/http2: add 4.1.2 (diff)
downloadgentoo-43bd73dae5b55bff1223990912da2928a95b0734.tar.gz
gentoo-43bd73dae5b55bff1223990912da2928a95b0734.tar.bz2
gentoo-43bd73dae5b55bff1223990912da2928a95b0734.zip
dev-haskell/http: Hackage revision bump
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/Manifest3
-rw-r--r--dev-haskell/http/http-4000.4.1-r1.ebuild (renamed from dev-haskell/http/http-4000.4.1.ebuild)24
-rw-r--r--dev-haskell/http/metadata.xml34
3 files changed, 16 insertions, 45 deletions
diff --git a/dev-haskell/http/Manifest b/dev-haskell/http/Manifest
index c3d8abe31ae8..04d7dc0b45e9 100644
--- a/dev-haskell/http/Manifest
+++ b/dev-haskell/http/Manifest
@@ -1 +1,2 @@
-DIST HTTP-4000.4.1.tar.gz 74330 BLAKE2B a4efc62f565609efb981c32961ad9fec28246fc67bbbc3da2c8430b7f4c2a96ee378b12b4f6f5f268353db870949cc6b04a9d8489c8f2bee70d783651a2bafc5 SHA512 c1edc529032013391263bcc0f8abd9534fc53a617b5033dfdc478318465cd988732b2644c7144979156c62bd1a08b1ace507b4fb4e2806f22ec7696cbdfd0147
+DIST http-4000.4.1-rev2.cabal 5862 BLAKE2B bd161e438c968d6bf20efc5bce869b5bae297b59a01332711176e34cd99f03d449f3ca8da178b5147703c2ecebe5c67f5405d98122d59fd796c8d6b23c2113f2 SHA512 03798e5436f1da1a6ecb66879f610b3b2a34d18f90c77b0724167c5931cb25b8e711316d413b7d2688c4eb2809bc957e9af2d10ad827986d026c71b2bed40a86
+DIST http-4000.4.1.tar.gz 74330 BLAKE2B a4efc62f565609efb981c32961ad9fec28246fc67bbbc3da2c8430b7f4c2a96ee378b12b4f6f5f268353db870949cc6b04a9d8489c8f2bee70d783651a2bafc5 SHA512 c1edc529032013391263bcc0f8abd9534fc53a617b5033dfdc478318465cd988732b2644c7144979156c62bd1a08b1ace507b4fb4e2806f22ec7696cbdfd0147
diff --git a/dev-haskell/http/http-4000.4.1.ebuild b/dev-haskell/http/http-4000.4.1-r1.ebuild
index e3c4474746ed..bf07dbb5578e 100644
--- a/dev-haskell/http/http-4000.4.1.ebuild
+++ b/dev-haskell/http/http-4000.4.1-r1.ebuild
@@ -3,36 +3,38 @@
EAPI=8
-# ebuild generated by hackport 0.7.1.2.9999
+# ebuild generated by hackport 0.8.2.1.9999
#hackport: flags: -warp-tests,-mtl1,-warn-as-error,-old-base,-network23,+network-uri,-conduit10
+CABAL_HACKAGE_REVISION=2
+CABAL_PN="HTTP"
+
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
-MY_PN="HTTP"
-MY_P="${MY_PN}-${PV}"
-S="${WORKDIR}/${MY_P}"
-
DESCRIPTION="A library for client-side HTTP"
HOMEPAGE="https://github.com/haskell/HTTP"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-RDEPEND=">=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
+RDEPEND="
+ >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
>=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?]
- >=dev-lang/ghc-8.4.3:=
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
- test? ( >=dev-haskell/httpd-shed-0.4 <dev-haskell/httpd-shed-0.5
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/httpd-shed-0.4 <dev-haskell/httpd-shed-0.5
>=dev-haskell/hunit-1.2.0.1 <dev-haskell/hunit-1.7
>=dev-haskell/puremd5-0.2.4 <dev-haskell/puremd5-2.2
>=dev-haskell/split-0.1.3 <dev-haskell/split-0.3
>=dev-haskell/test-framework-0.2.0 <dev-haskell/test-framework-0.9
- >=dev-haskell/test-framework-hunit-0.3.0 <dev-haskell/test-framework-hunit-0.4 )
+ >=dev-haskell/test-framework-hunit-0.3.0 <dev-haskell/test-framework-hunit-0.4
+ )
"
src_configure() {
diff --git a/dev-haskell/http/metadata.xml b/dev-haskell/http/metadata.xml
index 35fde4e13547..39f332301d58 100644
--- a/dev-haskell/http/metadata.xml
+++ b/dev-haskell/http/metadata.xml
@@ -5,40 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The HTTP package supports client-side web programming in Haskell. It lets you set up
- HTTP connections, transmitting requests and processing the responses coming back, all
- from within the comforts of Haskell. It's dependent on the network package to operate,
- but other than that, the implementation is all written in Haskell.
-
- A basic API for issuing single HTTP requests + receiving responses is provided. On top
- of that, a session-level abstraction is also on offer (the @BrowserAction@ monad);
- it taking care of handling the management of persistent connections, proxies,
- state (cookies) and authentication credentials required to handle multi-step
- interactions with a web server.
-
- The representation of the bytes flowing across is extensible via the use of a type class,
- letting you pick the representation of requests and responses that best fits your use.
- Some pre-packaged, common instances are provided for you (@ByteString@, @String@.)
-
- Here's an example use:
-
- &gt;
- &gt; do
- &gt; rsp &lt;- Network.HTTP.simpleHTTP (getRequest "http://www.haskell.org/")
- &gt; -- fetch document and return it (as a 'String'.)
- &gt; fmap (take 100) (getResponseBody rsp)
- &gt;
- &gt; do
- &gt; rsp &lt;- Network.Browser.browse $ do
- &gt; setAllowRedirects True -- handle HTTP redirects
- &gt; request $ getRequest "https://google.com/"
- &gt; fmap (take 100) (getResponseBody rsp)
- &gt;
-
- Git repository available at &lt;https://github.com/haskell/HTTP.git&gt;
- </longdescription>
<upstream>
+ <remote-id type="hackage">HTTP</remote-id>
<remote-id type="github">haskell/HTTP</remote-id>
</upstream>
</pkgmetadata>