summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-15 08:34:01 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-15 08:34:01 +0000
commitd6ff03002517c983c53103e4e32d19485a24d6ca (patch)
treed558e4dfe51556bf1d0e4b5373d543c7f1da9d48 /dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild
parentdev-haskell/cryptohash-sha256: new package, a depend of dev-haskell/cabal-ins... (diff)
downloadgentoo-d6ff03002517c983c53103e4e32d19485a24d6ca.tar.gz
gentoo-d6ff03002517c983c53103e4e32d19485a24d6ca.tar.bz2
gentoo-d6ff03002517c983c53103e4e32d19485a24d6ca.zip
dev-haskell/hackage-security: new package, a depend of dev-haskell/cabal-install-1.24.0.2
Hackage security library Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild')
-rw-r--r--dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild b/dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild
new file mode 100644
index 000000000000..845b6a3ad4fd
--- /dev/null
+++ b/dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage security library"
+HOMEPAGE="https://github.com/well-typed/hackage-security"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+use-network-uri"
+
+RDEPEND=">=dev-haskell/base16-bytestring-0.1.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/cabal-1.14:=[profile?] <dev-haskell/cabal-1.26:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?] <dev-haskell/cryptohash-sha256-0.12:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?] <dev-haskell/ed25519-0.1:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/tar-0.5:=[profile?] <dev-haskell/tar-0.6:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ >=dev-haskell/old-locale-1.0:=[profile?]
+ use-network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !use-network-uri? ( >=dev-haskell/network-2.5:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ dev-haskell/temporary
+ !use-network-uri? ( dev-haskell/network-uri ) )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'directory >= 1.1.0.2 && < 1.3' 'directory >= 1.1.0.2'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag use-network-uri use-network-uri)
+}