summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-05-28 09:12:44 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-15 21:21:44 +0200
commit59bf48d2d6c22a57f7125dd8980135df2478dd08 (patch)
tree98ef2e7a25a60249ffbaa314855344d91fb04af5 /dev-debug
parentdev-libs/libdex: Bump to 0.6.1 (diff)
downloadgentoo-59bf48d2d6c22a57f7125dd8980135df2478dd08.tar.gz
gentoo-59bf48d2d6c22a57f7125dd8980135df2478dd08.tar.bz2
gentoo-59bf48d2d6c22a57f7125dd8980135df2478dd08.zip
dev-debug/d-spy: Bump to 1.10.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36870 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/d-spy/Manifest1
-rw-r--r--dev-debug/d-spy/d-spy-1.10.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-debug/d-spy/Manifest b/dev-debug/d-spy/Manifest
index 124cc8dc61b1..ecd9544cef2a 100644
--- a/dev-debug/d-spy/Manifest
+++ b/dev-debug/d-spy/Manifest
@@ -1 +1,2 @@
+DIST d-spy-1.10.0.tar.xz 213044 BLAKE2B acb4d99e6f9be8ed86685c9deeb705727ac2b9522e701daa38e7baa84d37a585effda9c871d2cce814fff4dc240c585b6679d95a56b457434d0ce9e721ce3e29 SHA512 89f28ac2cc1799f7ad053da0c3995627c567ec224dc2267aac2fe6a2305d8580712c2ae3b4a86f86547f4bd7ac0462d2c6768bee3049cb449c4b6b00ce216cd6
DIST d-spy-1.8.0.tar.xz 232944 BLAKE2B cb6f90e9b3d779aa5a76bc93f16e9ae677af029b72451bbb983ffeb06b99a92aa2402ef8b6f6a6c6b4ad4f6ba49a924db37d7e9fc9cb98157a6475a0ec234267 SHA512 49c0ff250a91110014f98453ed6958cf4b5191cc0c8d31c5e63b1408864eaf0906ab3860b0479400a04a8614ee36fe5b9527b179e6346bdb5616cb188d2648f0
diff --git a/dev-debug/d-spy/d-spy-1.10.0.ebuild b/dev-debug/d-spy/d-spy-1.10.0.ebuild
new file mode 100644
index 000000000000..fdb3b82692ba
--- /dev/null
+++ b/dev-debug/d-spy/d-spy-1.10.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="D-Spy is a simple tool to explore D-Bus connections"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/d-spy"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ >=dev-libs/glib-2.76:2
+ >=gui-libs/gtk-4.12:4
+ >=gui-libs/libadwaita-1.4:1
+"
+RDEPEND="
+ ${DEPEND}
+ >=sys-apps/dbus-1
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}