summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-12 00:56:28 +0100
committerSam James <sam@gentoo.org>2024-09-12 00:58:31 +0100
commit063c07a77f3d3b04649bf1e00bc90b1fcd316d1a (patch)
treeee0118cbf3fd1b4b8244bf29b3c791d2555d3e20 /dev-debug
parentsys-libs/glibc: add 2.40-r3, patchlevel 3, unkeyworded (diff)
downloadgentoo-063c07a77f3d3b04649bf1e00bc90b1fcd316d1a.tar.gz
gentoo-063c07a77f3d3b04649bf1e00bc90b1fcd316d1a.tar.bz2
gentoo-063c07a77f3d3b04649bf1e00bc90b1fcd316d1a.zip
dev-debug/dtrace: rename USE=install-tests -> USE=test-install
Following discussion with mgorny and us agreeing to use test-install for Python. Bug: https://bugs.gentoo.org/531648 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/dtrace/dtrace-2.0.1.1-r2.ebuild10
-rw-r--r--dev-debug/dtrace/dtrace-9999.ebuild10
-rw-r--r--dev-debug/dtrace/metadata.xml2
3 files changed, 11 insertions, 11 deletions
diff --git a/dev-debug/dtrace/dtrace-2.0.1.1-r2.ebuild b/dev-debug/dtrace/dtrace-2.0.1.1-r2.ebuild
index 0cc975299382..413cba677aed 100644
--- a/dev-debug/dtrace/dtrace-2.0.1.1-r2.ebuild
+++ b/dev-debug/dtrace/dtrace-2.0.1.1-r2.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="UPL-1.0"
SLOT="0"
-IUSE="systemd install-tests"
+IUSE="systemd test-install"
# XXX: right now, we auto-adapt to whether multilibs are present:
# should we force them to be? how?
@@ -44,7 +44,7 @@ RDEPEND="
${DEPEND}
!dev-debug/systemtap[dtrace-symlink(+)]
net-analyzer/wireshark
- install-tests? (
+ test-install? (
app-alternatives/bc
app-editors/vim-core
dev-build/make
@@ -96,7 +96,7 @@ pkg_pretend() {
# https://gcc.gnu.org/PR84052
CONFIG_CHECK+=" !GCC_PLUGIN_RANDSTRUCT"
- if use install-tests ; then
+ if use test-install ; then
# See test/modules
CONFIG_CHECK+=" ~EXT4_FS ~ISO9660_FS ~NFS_FS ~RDS ~TUN"
fi
@@ -147,7 +147,7 @@ src_configure() {
src_compile() {
# -j1: https://github.com/oracle/dtrace-utils/issues/82
- emake verbose=1 -j1 $(usev !install-tests TRIGGERS='')
+ emake verbose=1 -j1 $(usev !test-install TRIGGERS='')
}
src_test() {
@@ -156,7 +156,7 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" -j1 install $(usev install-tests install-test)
+ emake DESTDIR="${D}" -j1 install $(usev test-install install-test)
# Stripping the BPF libs breaks them
dostrip -x "/usr/$(get_libdir)"
diff --git a/dev-debug/dtrace/dtrace-9999.ebuild b/dev-debug/dtrace/dtrace-9999.ebuild
index 69752d8625d4..1b544c426da4 100644
--- a/dev-debug/dtrace/dtrace-9999.ebuild
+++ b/dev-debug/dtrace/dtrace-9999.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="UPL-1.0"
SLOT="0"
-IUSE="systemd install-tests"
+IUSE="systemd test-install"
# XXX: right now, we auto-adapt to whether multilibs are present:
# should we force them to be? how?
@@ -44,7 +44,7 @@ RDEPEND="
${DEPEND}
!dev-debug/systemtap[dtrace-symlink(+)]
net-analyzer/wireshark
- install-tests? (
+ test-install? (
app-alternatives/bc
app-editors/vim-core
dev-build/make
@@ -96,7 +96,7 @@ pkg_pretend() {
# https://gcc.gnu.org/PR84052
CONFIG_CHECK+=" !GCC_PLUGIN_RANDSTRUCT"
- if use install-tests ; then
+ if use test-install ; then
# See test/modules
CONFIG_CHECK+=" ~EXT4_FS ~ISO9660_FS ~NFS_FS ~RDS ~TUN"
fi
@@ -147,7 +147,7 @@ src_configure() {
src_compile() {
# -j1: https://github.com/oracle/dtrace-utils/issues/82
- emake verbose=1 -j1 $(usev !install-tests TRIGGERS='')
+ emake verbose=1 -j1 $(usev !test-install TRIGGERS='')
}
src_test() {
@@ -156,7 +156,7 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" -j1 install $(usev install-tests install-test)
+ emake DESTDIR="${D}" -j1 install $(usev test-install install-test)
# Stripping the BPF libs breaks them
dostrip -x "/usr/$(get_libdir)"
diff --git a/dev-debug/dtrace/metadata.xml b/dev-debug/dtrace/metadata.xml
index 00989594025b..815fdabd199d 100644
--- a/dev-debug/dtrace/metadata.xml
+++ b/dev-debug/dtrace/metadata.xml
@@ -10,7 +10,7 @@
<description>Arsen Arsenović</description>
</maintainer>
<use>
- <flag name="install-tests">
+ <flag name="test-install">
Install the testsuite for manual use. It is not suitable
for automatic execution within the ebuild because it
requires root privlieges.