summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-01 08:51:37 +0000
committerSam James <sam@gentoo.org>2024-12-01 08:51:47 +0000
commit13e92531b953583d1f5049fbed2c68645f6f968c (patch)
tree328b7b02928708136c37e725f4268e3279259f7a /dev-debug/gdb
parenttoolchain.eclass: add more mirrors to EGIT_REPO_URI (diff)
downloadgentoo-13e92531b953583d1f5049fbed2c68645f6f968c.tar.gz
gentoo-13e92531b953583d1f5049fbed2c68645f6f968c.tar.bz2
gentoo-13e92531b953583d1f5049fbed2c68645f6f968c.zip
dev-debug/gdb: add mirrors to EGIT_REPO_URI
sourceware was down earlier, so add some mirrors. sourcehut is an official mirror (albeit an experiment IIRC) by sourceware and x86-binutils is run by H.J. Lu. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug/gdb')
-rw-r--r--dev-debug/gdb/gdb-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-debug/gdb/gdb-9999.ebuild b/dev-debug/gdb/gdb-9999.ebuild
index 811789dab6d8..039c98a9e0ca 100644
--- a/dev-debug/gdb/gdb-9999.ebuild
+++ b/dev-debug/gdb/gdb-9999.ebuild
@@ -23,7 +23,11 @@ is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
case ${PV} in
9999*)
# live git tree
- EGIT_REPO_URI="https://sourceware.org/git/binutils-gdb.git"
+ EGIT_REPO_URI="
+ https://sourceware.org/git/binutils-gdb.git
+ https://git.sr.ht/~sourceware/binutils-gdb
+ https://gitlab.com/x86-binutils/binutils-gdb.git
+ "
inherit git-r3
SRC_URI=""
;;