summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-11-28 06:25:18 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-11-28 06:25:55 -0500
commit7b1bad3a6068b974161b6404cb21a85227637e6e (patch)
tree463c5e7bf1f6a4436ea5a3d7b1a182a311771958 /dev-db
parentdev-db/pgpool2: Bump to 3.7.7, 4.0.2 (diff)
downloadgentoo-7b1bad3a6068b974161b6404cb21a85227637e6e.tar.gz
gentoo-7b1bad3a6068b974161b6404cb21a85227637e6e.tar.bz2
gentoo-7b1bad3a6068b974161b6404cb21a85227637e6e.zip
dev-db/pgtap: Bump to 0.99.0
Ebuild now restricts tests. Bug: https://bugs.gentoo.org/663792 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgtap/Manifest1
-rw-r--r--dev-db/pgtap/pgtap-0.99.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/pgtap/Manifest b/dev-db/pgtap/Manifest
index d36b43d654d5..bacf450982fd 100644
--- a/dev-db/pgtap/Manifest
+++ b/dev-db/pgtap/Manifest
@@ -1 +1,2 @@
DIST pgtap-0.98.0.zip 270583 BLAKE2B 25d409f5fc63bc7059e8a4ffd3cb460885648f8569cd10ca05d4c5fbe09af323ecc719d663f81389d45f4a4910ca77beef968e264a0d3f4fabf63fa30b8b98ac SHA512 478841aa9cf378120713b90f33dc16d40fdd030ee1856edd4bfa288a7803cabad09661cf5219925335d9220e12b6202a1fcd8cc0fc55d1974d1e98dc0f6ddac0
+DIST pgtap-0.99.0.zip 275915 BLAKE2B 33499dacc0019ecbe85ff3dc4fcc243b6102e0b7e7018d70b17cda44b8d22d8260229ab732db9900296232e0801070722bf97a752734ea7d389dc8ae57198b6f SHA512 c1b39bf2c041d759006d692229a67af1520b6a3d23fdac43f0781cac9ce69e7714fc854d1e45f1cb3ee188a20dccfb7904bc4dd1513699189fae70f425c13b5f
diff --git a/dev-db/pgtap/pgtap-0.99.0.ebuild b/dev-db/pgtap/pgtap-0.99.0.ebuild
new file mode 100644
index 000000000000..2be40ea3ba4a
--- /dev/null
+++ b/dev-db/pgtap/pgtap-0.99.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{3..6} {10..11} )
+
+inherit postgres-multi
+
+DESCRIPTION="Unit testing for PostgreSQL"
+HOMEPAGE="https://pgtap.org/"
+SRC_URI="https://api.pgxn.org/dist/${PN}/${PV}/${P}.zip"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/unzip
+ dev-perl/TAP-Parser-SourceHandler-pgTAP
+"
+RDEPEND="${DEPEND}"
+
+# Tests requires a running database that match up with the current testing slot.
+RESTRICT="test"
+
+src_configure() {
+ :
+}