summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2022-03-17 10:30:11 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2022-03-17 10:37:27 -0400
commit98f188b45eefa86a191b908da93851f38fc5eccc (patch)
tree696104c94f4937d7e837d0e8b61ce925c1007805 /dev-db/pgtap
parentsci-mathematics/octave: add upstream patch for slibtool support. (diff)
downloadgentoo-98f188b45eefa86a191b908da93851f38fc5eccc.tar.gz
gentoo-98f188b45eefa86a191b908da93851f38fc5eccc.tar.bz2
gentoo-98f188b45eefa86a191b908da93851f38fc5eccc.zip
dev-db/pgtap: Fix unexpected paths, support Pg 14
Bug: https://bugs.gentoo.org/801097 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgtap')
-rw-r--r--dev-db/pgtap/pgtap-1.2.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/pgtap/pgtap-1.2.0-r1.ebuild b/dev-db/pgtap/pgtap-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..747da8ca2c29
--- /dev/null
+++ b/dev-db/pgtap/pgtap-1.2.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 {10..14} )
+
+inherit postgres-multi
+
+DESCRIPTION="Unit testing for PostgreSQL"
+HOMEPAGE="https://pgtap.org/"
+SRC_URI="https://api.pgxn.org/dist/${PN}/${PV}/${P}.zip"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/unzip
+ dev-perl/TAP-Parser-SourceHandler-pgTAP
+"
+RDEPEND="${DEPEND}"
+
+# Tests requires a running database that match up with the current
+# testing slot. Won't run from ${ED}, want's to install too early.
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_install() {
+ default
+
+ rm -r ${ED}/usr/share/doc/postgresql* || die "Failed to remove improper doc locations"
+ dodoc doc/pgtap.mmd
+}