summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/lmdb++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/lmdb++')
-rw-r--r--dev-db/lmdb++/Manifest1
-rw-r--r--dev-db/lmdb++/lmdb++-0.9.14.0.ebuild24
-rw-r--r--dev-db/lmdb++/metadata.xml16
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-db/lmdb++/Manifest b/dev-db/lmdb++/Manifest
new file mode 100644
index 000000000000..c403bd5e8fe0
--- /dev/null
+++ b/dev-db/lmdb++/Manifest
@@ -0,0 +1 @@
+DIST lmdbxx-0.9.14.0.tar.gz 14732 SHA256 f74c55184bff19de607948a5f00fe1073de5b59c4309ab2e8ebc488cf675f419 SHA512 8eff8c89e0cb9989d8a0cedfd483856aeb2fcf810d59cf8afca3086034711ff22f2bb88ba967ef745d36fdaa1b5e79fb75655af764cddcdb2ac59fc255da670d WHIRLPOOL ab023a06e43d8f5189a83dc6eaf04b632eff83c028991ff440fd06a3c7f582f2aa0cf0332ef182837194979fbabb3a4cab6df7252d06455baec498db1941a635
diff --git a/dev-db/lmdb++/lmdb++-0.9.14.0.ebuild b/dev-db/lmdb++/lmdb++-0.9.14.0.ebuild
new file mode 100644
index 000000000000..8dc44ea5464d
--- /dev/null
+++ b/dev-db/lmdb++/lmdb++-0.9.14.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${P/lmdb++/lmdbxx}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C++11 wrapper for the LMDB database library"
+HOMEPAGE="http://lmdbxx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lmdbxx/${PV}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/lmdb"
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc AUTHORS CREDITS INSTALL README TODO UNLICENSE
+}
diff --git a/dev-db/lmdb++/metadata.xml b/dev-db/lmdb++/metadata.xml
new file mode 100644
index 000000000000..834fd0316544
--- /dev/null
+++ b/dev-db/lmdb++/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a comprehensive C++ wrapper for the LMDB embedded database
+ library, offering both an error-checked procedural interface and an
+ object-oriented resource interface with RAII semantics.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">lmdbxx</remote-id>
+ </upstream>
+</pkgmetadata>