summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-13 00:03:04 +0000
committerSam James <sam@gentoo.org>2024-11-23 14:00:57 +0000
commite6ae95c0515b0a8859df3052d48500473cd6e457 (patch)
treecc3e6ee2c52c949b92b0ec63b58752c07086c4ee /dev-cpp
parentdev-cpp/folly: skip some tests on arm64 (diff)
downloadgentoo-e6ae95c0515b0a8859df3052d48500473cd6e457.tar.gz
gentoo-e6ae95c0515b0a8859df3052d48500473cd6e457.tar.bz2
gentoo-e6ae95c0515b0a8859df3052d48500473cd6e457.zip
dev-cpp/mvfst: skip some tests on arm64
These tests segfault in a QEMU chroot. Signed-off-by: sin-ack <sin-ack@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild b/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
index b920ce229a20..12d43e1df1c3 100644
--- a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
+++ b/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
@@ -47,3 +47,16 @@ src_configure() {
cmake_src_configure
}
+
+src_test() {
+ if use arm64; then
+ # These tests segfault on arm64.
+ # https://github.com/facebook/mvfst/issues/363
+ CMAKE_SKIP_TESTS=(
+ QuicClientTransportIntegrationTest.ResetClient
+ QuicClientTransportIntegrationTest.TestStatelessResetToken
+ )
+ fi
+
+ cmake_src_test
+}