summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-31 21:59:12 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-31 22:11:17 -0400
commitb885f2af64f60f2114d95d83dadde49dc3375beb (patch)
treec96b4af78c0c88074e894c3659f246019b693fe8 /dev-cpp
parentsys-kernel/gentoo-kernel-bin: bump to 5.11.11 for arm64 (diff)
downloadgentoo-b885f2af64f60f2114d95d83dadde49dc3375beb.tar.gz
gentoo-b885f2af64f60f2114d95d83dadde49dc3375beb.tar.bz2
gentoo-b885f2af64f60f2114d95d83dadde49dc3375beb.zip
dev-cpp/glibmm: Version bump to 2.64.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.64.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index a6ee6004d98f..ff809e3ac3a9 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,2 +1,3 @@
DIST glibmm-2.64.2.tar.xz 7438116 BLAKE2B 6ff458e90a5dbc606a2e04ecd3589262a1b96e827dba245985467818a7a4ba80a9c4cb15686fe479636cb8ce7e1db3334195d6334d7ec56327076cad87e22170 SHA512 0130af9a16981a54630150db6f4b1a95458d72d650c5e4781ee97ce624ec98c600b79ebf234d212e025781453fd11d78b9e8273235ffa143397423418fe970cc
+DIST glibmm-2.64.5.tar.xz 7491108 BLAKE2B 3c0f2215542a6ccc65c37d566856df326b7c0d45999e525df6153862edd0841c501c64fc3cfd0e4c3f1bae29bbaca1eed44738acc11b3f1515ffc8a396b0791f SHA512 e90bb722a35292b0fc54dff82604ec8d23a9e72b08581de14fd515539392ed713d0691352bf7de42d5027579959f76b268cdc11a76a3d3033ae8268f486ee817
DIST glibmm-2.68.0.tar.xz 7652260 BLAKE2B df87b3f3d8cd74b693f843dec15d5376f2a755b0a72042983383c15cca9fdb90c2fed6320bf0f3fe846fcda5be3ee15c0fc1b683d29cebe64e8dcdd101fc9bf0 SHA512 a13121052315e949acf2528e226079f1a2cf7853080aec770dcb269e422997e5515ed767c7a549231fb3fa5f913b3fd9ef083080589283824b6a218d066b253e
diff --git a/dev-cpp/glibmm/glibmm-2.64.5.ebuild b/dev-cpp/glibmm/glibmm-2.64.5.ebuild
new file mode 100644
index 000000000000..db0034cef750
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.64.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.61.2:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ >=dev-cpp/mm-common-1.0.0
+ sys-devel/m4
+ dev-lang/perl
+ doc? (
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ )
+"
+
+src_prepare() {
+ default
+
+ # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
+ sed -i -e '/giomm_tls_client/d' tests/meson.build || die
+
+ if ! use test; then
+ sed -i -e "/^subdir('tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dmaintainer-mode=true # Set false and drop mm-common dep once tarballs are made with meson/ninja
+ -Dwarnings=min
+ -Dbuild-deprecated-api=true
+ -Dbuild-documentation=$(usex doc true false)
+ -Ddebug-refcounting=$(usex debug true false)
+ -Dbuild-examples=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}