summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:09:36 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:11 +0100
commitb060a63ee02c38b2fa87212b3770c0d016bf3af7 (patch)
tree7ece9dabf8d25d95e18c38970ce4b98c92b5912c /dev-cpp
parentMove {dev-libs/libclc → llvm-core/libclc} (diff)
downloadgentoo-b060a63ee02c38b2fa87212b3770c0d016bf3af7.tar.gz
gentoo-b060a63ee02c38b2fa87212b3770c0d016bf3af7.tar.bz2
gentoo-b060a63ee02c38b2fa87212b3770c0d016bf3af7.zip
Move sys-libs/llvm-libunwind → llvm-runtimes/libunwind
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild4
-rw-r--r--dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild2
-rw-r--r--dev-cpp/folly/folly-2023.06.19.00-r1.ebuild2
-rw-r--r--dev-cpp/folly/folly-2024.11.04.00-r2.ebuild2
-rw-r--r--dev-cpp/glog/glog-0.5.0.ebuild4
-rw-r--r--dev-cpp/glog/glog-0.6.0.ebuild2
-rw-r--r--dev-cpp/glog/metadata.xml2
7 files changed, 9 insertions, 9 deletions
diff --git a/dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild b/dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild
index 1296800f7058..6c401a0596e4 100644
--- a/dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild
+++ b/dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ RDEPEND="
dev-cpp/gflags:=
dev-cpp/glog:=[gflags]
dev-cpp/folly:=
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ llvm-libunwind? ( llvm-runtimes/libunwind:= )
!llvm-libunwind? ( sys-libs/libunwind:= )
"
DEPEND="
diff --git a/dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild b/dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild
index bd951c699e39..feba00c2add7 100644
--- a/dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild
+++ b/dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild
@@ -31,7 +31,7 @@ RDEPEND="
~dev-cpp/fb303-${PV}:=
~dev-cpp/wangle-${PV}:=
~dev-cpp/fbthrift-${PV}:=
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ llvm-libunwind? ( llvm-runtimes/libunwind:= )
!llvm-libunwind? ( sys-libs/libunwind:= )
"
DEPEND="
diff --git a/dev-cpp/folly/folly-2023.06.19.00-r1.ebuild b/dev-cpp/folly/folly-2023.06.19.00-r1.ebuild
index 4f87b7aa969f..0257d178791a 100644
--- a/dev-cpp/folly/folly-2023.06.19.00-r1.ebuild
+++ b/dev-cpp/folly/folly-2023.06.19.00-r1.ebuild
@@ -37,7 +37,7 @@ RDEPEND="
dev-libs/openssl:=
>=sys-libs/liburing-2.3:=
sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ llvm-libunwind? ( llvm-runtimes/libunwind:= )
!llvm-libunwind? ( sys-libs/libunwind:= )
"
# libiberty is linked statically
diff --git a/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild b/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
index d861968c9242..166726ddaf3e 100644
--- a/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
+++ b/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
@@ -43,7 +43,7 @@ RDEPEND="
dev-libs/openssl:=
>=sys-libs/liburing-2.3:=
sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ llvm-libunwind? ( llvm-runtimes/libunwind:= )
!llvm-libunwind? ( sys-libs/libunwind:= )
"
# libiberty is linked statically
diff --git a/dev-cpp/glog/glog-0.5.0.ebuild b/dev-cpp/glog/glog-0.5.0.ebuild
index 6e7df7821fe7..4a54a63a949a 100644
--- a/dev-cpp/glog/glog-0.5.0.ebuild
+++ b/dev-cpp/glog/glog-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2011-2022 Gentoo Authors
+# Copyright 2011-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -27,7 +27,7 @@ RESTRICT="!test? ( test )"
RDEPEND="gflags? ( dev-cpp/gflags:0=[${MULTILIB_USEDEP}] )
libunwind? (
- llvm-libunwind? ( sys-libs/llvm-libunwind:0=[${MULTILIB_USEDEP}] )
+ llvm-libunwind? ( llvm-runtimes/libunwind:0=[${MULTILIB_USEDEP}] )
!llvm-libunwind? ( sys-libs/libunwind:0=[${MULTILIB_USEDEP}] )
)"
DEPEND="${RDEPEND}
diff --git a/dev-cpp/glog/glog-0.6.0.ebuild b/dev-cpp/glog/glog-0.6.0.ebuild
index 6192cd198dbb..ed6817c72644 100644
--- a/dev-cpp/glog/glog-0.6.0.ebuild
+++ b/dev-cpp/glog/glog-0.6.0.ebuild
@@ -27,7 +27,7 @@ RESTRICT="!test? ( test )"
RDEPEND="gflags? ( dev-cpp/gflags:0=[${MULTILIB_USEDEP}] )
libunwind? (
- llvm-libunwind? ( sys-libs/llvm-libunwind:0=[${MULTILIB_USEDEP}] )
+ llvm-libunwind? ( llvm-runtimes/libunwind:0=[${MULTILIB_USEDEP}] )
!llvm-libunwind? ( sys-libs/libunwind:0=[${MULTILIB_USEDEP}] )
)
"
diff --git a/dev-cpp/glog/metadata.xml b/dev-cpp/glog/metadata.xml
index f488a88cb0cf..bbbd4c7947cd 100644
--- a/dev-cpp/glog/metadata.xml
+++ b/dev-cpp/glog/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<use>
<flag name="gflags">Use <pkg>dev-cpp/gflags</pkg> for flag parsing</flag>
- <flag name="libunwind">Use libunwind library (<pkg>sys-libs/libunwind</pkg> or <pkg>sys-libs/llvm-libunwind</pkg>) instead of built-in fallback implementation for stack unwinding</flag>
+ <flag name="libunwind">Use libunwind library (<pkg>sys-libs/libunwind</pkg> or <pkg>llvm-runtimes/libunwind</pkg>) instead of built-in fallback implementation for stack unwinding</flag>
</use>
<upstream>
<remote-id type="github">google/glog</remote-id>