summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-04 19:48:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-04 21:23:20 +0300
commit5884189496a9003a3e3cf6171efaab17133bf79b (patch)
tree553a570a99ad5d22503b1989fcd8c4a11d21ea09 /dev-cpp
parentdev-python/meson-python: Remove old (diff)
downloadgentoo-5884189496a9003a3e3cf6171efaab17133bf79b.tar.gz
gentoo-5884189496a9003a3e3cf6171efaab17133bf79b.tar.bz2
gentoo-5884189496a9003a3e3cf6171efaab17133bf79b.zip
dev-cpp/valijson: add 1.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/valijson/Manifest1
-rw-r--r--dev-cpp/valijson/valijson-1.0.2.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-cpp/valijson/Manifest b/dev-cpp/valijson/Manifest
index b112a7c010c0..e485a9f791ba 100644
--- a/dev-cpp/valijson/Manifest
+++ b/dev-cpp/valijson/Manifest
@@ -1 +1,2 @@
+DIST valijson-1.0.2.tar.gz 723131 BLAKE2B ada64202d1c82f4e24c8fb3935a070ee40a24e8b75712fd4392f19c93c363d293db788cd1481ed3a857721fcd6f87e2d91c3b9779863fb6e2421ba4ee4f1d1f7 SHA512 c1141e533d6a791a01883c5b7ab9501eebc39057a850d784670a4bcf99bff3fee4c3120107128dcaa9db0505adf2ae794700620c02163b3e636f0b635031df80
DIST valijson-1.0.tar.gz 721078 BLAKE2B 74f4a061266a6ee8fba9d93b4e1df20dc828d85169f865bdb60ba9f5217ee422324a09788b02b4ddd18a92d906c64863a5bd7c1250f8bdb62fd9f00f3d73c7e7 SHA512 a206954b11e92cbebbebf094e6f0925a270ebd6bec49cbdb7adda5a4cec93587a5a61ebbce105846c3950cf5df74bfdd5f5bb1ffbf73315f45c7a6cda2b77db9
diff --git a/dev-cpp/valijson/valijson-1.0.2.ebuild b/dev-cpp/valijson/valijson-1.0.2.ebuild
new file mode 100644
index 000000000000..b0c20539683e
--- /dev/null
+++ b/dev-cpp/valijson/valijson-1.0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Header-only C++ library for JSON Schema validation"
+HOMEPAGE="https://github.com/tristanpenman/valijson"
+SRC_URI="https://github.com/tristanpenman/valijson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+RESTRICT="test"
+
+src_install() {
+ # there is no target for installing headers, so do it manually
+ doheader -r include/*
+}