summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-10 20:53:10 +0100
committerSam James <sam@gentoo.org>2024-11-11 22:24:16 +0000
commit513b5fedf5187ffdad91ce6de841b24eb57b8b2e (patch)
treeb9bd7a0346ddb4b33d3b8f6d7968e0c1c58b7d21 /dev-cpp/mvfst
parentdev-cpp/fizz: new package, add 2024.11.04.00 (diff)
downloadgentoo-513b5fedf5187ffdad91ce6de841b24eb57b8b2e.tar.gz
gentoo-513b5fedf5187ffdad91ce6de841b24eb57b8b2e.tar.bz2
gentoo-513b5fedf5187ffdad91ce6de841b24eb57b8b2e.zip
dev-cpp/mvfst: new package, add 2024.11.04.00
Signed-off-by: sin-ack <sin-ack@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/mvfst')
-rw-r--r--dev-cpp/mvfst/Manifest1
-rw-r--r--dev-cpp/mvfst/metadata.xml15
-rw-r--r--dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild49
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-cpp/mvfst/Manifest b/dev-cpp/mvfst/Manifest
new file mode 100644
index 000000000000..404d5e40b48e
--- /dev/null
+++ b/dev-cpp/mvfst/Manifest
@@ -0,0 +1 @@
+DIST mvfst-2024.11.04.00.gh.tar.gz 1983543 BLAKE2B 9c8b0da32baddd04af29e892a379333f89af45957a415dfa7f6da86f9a9b39fc8fbc73e450deb51e7a61b4ddfd37f08dc3d9ba8f48f83557aab4ae762068ec14 SHA512 4a000583884777fa876f3bfc52a3420c9cf8818f943c07898ac3b313837092fc173d8db497fd59027ef405d8fa5e3114a53b3bc5cf3fef398ca712c06a1da3e0
diff --git a/dev-cpp/mvfst/metadata.xml b/dev-cpp/mvfst/metadata.xml
new file mode 100644
index 000000000000..48c4665d7f55
--- /dev/null
+++ b/dev-cpp/mvfst/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sin-ack@protonmail.com</email>
+ <name>sin-ack</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facebook/mvfst</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild b/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
new file mode 100644
index 000000000000..b920ce229a20
--- /dev/null
+++ b/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/fb303
+# dev-cpp/fbthrift
+# dev-cpp/fizz
+# dev-cpp/folly
+# dev-cpp/mvfst
+# dev-cpp/wangle
+# dev-util/watchman
+
+inherit cmake
+
+DESCRIPTION="An implementation of the QUIC transport protocol"
+HOMEPAGE="https://github.com/facebook/mvfst"
+SRC_URI="https://github.com/facebook/mvfst/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ~dev-cpp/fizz-${PV}:=
+ ~dev-cpp/folly-${PV}:=
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ dev-libs/boost:=
+ dev-libs/libfmt:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ -DBUILD_TESTS="$(usex test ON OFF)"
+ )
+
+ cmake_src_configure
+}