summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaolo Pedroni <paolo.pedroni@iol.it>2022-03-30 18:03:13 +0200
committerMatt Turner <mattst88@gentoo.org>2022-04-05 23:26:46 -0700
commite6426d5f35e2fb9cc596fe69425c0338ca5b4496 (patch)
treed0420fb9e932c8a1a075cd8590dd68befb2b8952 /dev-cpp/highway/highway-0.16.0.ebuild
parentprofiles/arch/riscv: Umnask media-libs/opencv[contribsfm,glog] (diff)
downloadgentoo-e6426d5f35e2fb9cc596fe69425c0338ca5b4496.tar.gz
gentoo-e6426d5f35e2fb9cc596fe69425c0338ca5b4496.tar.bz2
gentoo-e6426d5f35e2fb9cc596fe69425c0338ca5b4496.zip
dev-cpp/highway: Fix detection of AVX512 for IceLake Client CPUs
Closes: https://bugs.gentoo.org/836373 Closes: https://github.com/gentoo/gentoo/pull/24819 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/highway/highway-0.16.0.ebuild')
-rw-r--r--dev-cpp/highway/highway-0.16.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-cpp/highway/highway-0.16.0.ebuild b/dev-cpp/highway/highway-0.16.0.ebuild
deleted file mode 100644
index 89b07a85a587..000000000000
--- a/dev-cpp/highway/highway-0.16.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib
-
-DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
-HOMEPAGE="https://github.com/google/highway"
-
-if [[ "${PV}" == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/google/highway.git"
-else
- SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
-
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test)
- -DHWY_WARNINGS_ARE_ERRORS=OFF
- )
-
- use test && mycmakeargs+=( "-DHWY_SYSTEM_GTEST=ON" )
-
- cmake_src_configure
-}