summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-05 13:29:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-05 13:36:51 +0300
commit4a68e4691b418ceac53660399b874f796fd723c4 (patch)
tree2aa2a94dda8e8dc04b2f7727bffd2b4575ae92d0 /app-vim
parentdev-java/injection-api: fixed source path + ordered vars (diff)
downloadgentoo-4a68e4691b418ceac53660399b874f796fd723c4.tar.gz
gentoo-4a68e4691b418ceac53660399b874f796fd723c4.tar.bz2
gentoo-4a68e4691b418ceac53660399b874f796fd723c4.zip
app-vim/iris: EAPI=8, enable py3.11, py3.12
Closes: https://bugs.gentoo.org/896652 Closes: https://bugs.gentoo.org/929373 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/iris/iris-1.0.0-r1.ebuild (renamed from app-vim/iris/iris-1.0.0.ebuild)12
1 files changed, 4 insertions, 8 deletions
diff --git a/app-vim/iris/iris-1.0.0.ebuild b/app-vim/iris/iris-1.0.0-r1.ebuild
index 984316d0a73f..c085f852da3e 100644
--- a/app-vim/iris/iris-1.0.0.ebuild
+++ b/app-vim/iris/iris-1.0.0-r1.ebuild
@@ -1,23 +1,19 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit vim-plugin python-r1
-MY_PN="iris.vim"
-MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="vim plugin: mail client for vim"
HOMEPAGE="https://github.com/soywod/iris.vim"
SRC_URI="https://github.com/soywod/iris.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/iris.vim-${PV}"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
-
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}