summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-04-08 21:28:14 +0100
committerMarek Szuba <marecki@gentoo.org>2023-04-08 21:56:26 +0100
commit2e5f1f7d908e71f9c03b28be72476f518f4a73f7 (patch)
tree0ec05fe0ec7ba501a78793149451180480abdae5 /app-vim/fugitive
parentapp-vim/vim-flake8: add 1.7 (diff)
downloadgentoo-2e5f1f7d908e71f9c03b28be72476f518f4a73f7.tar.gz
gentoo-2e5f1f7d908e71f9c03b28be72476f518f4a73f7.tar.bz2
gentoo-2e5f1f7d908e71f9c03b28be72476f518f4a73f7.zip
app-vim/fugitive: add 3.7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-vim/fugitive')
-rw-r--r--app-vim/fugitive/Manifest1
-rw-r--r--app-vim/fugitive/fugitive-3.7.ebuild25
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild7
3 files changed, 31 insertions, 2 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index 56385baa04c1..79631cc0c30a 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -1 +1,2 @@
DIST fugitive-3.4.tar.gz 80677 BLAKE2B 7cb341851248eb05a8094617f349e382cb8704f69116d8a00f07db40d96b4cc86b98515a59c489116fe7fdadb9a73a65819bf792005bda316f1a0bca311e6938 SHA512 313f1b06c843f85cfdbee059f1470b1ed062c2055e552fa1e05b01e59d9950c181b19e7553cbbca575b1951949970691081582128be7148885485d4fbed0a4d2
+DIST fugitive-3.7.tar.gz 84271 BLAKE2B 1c00272174bd76a2b4d34aa54a7498b2f75a5322d587e3436d82f21d6188027768bea0475c99fcbc50a82b89d9a9a7697d18106cb1eb2f9788afa81848fe2de8 SHA512 8252b69c6183f5b710739eb68ecb3fbdfad52df3dbee0a3a04ad33f410b489d7fcf1c0bde0cb2d53995a6b4e34191c165c652d08e6145789a88f8c46bfcddf56
diff --git a/app-vim/fugitive/fugitive-3.7.ebuild b/app-vim/fugitive/fugitive-3.7.ebuild
new file mode 100644
index 000000000000..e0e4ec9939dc
--- /dev/null
+++ b/app-vim/fugitive/fugitive-3.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+
+LICENSE="vim"
+SLOT="0"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
index 0d4da8993529..e0e4ec9939dc 100644
--- a/app-vim/fugitive/fugitive-9999.ebuild
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit vim-plugin
if [[ ${PV} == 9999 ]]; then
@@ -15,7 +16,9 @@ fi
DESCRIPTION="vim plugin: a git wrapper for vim"
HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+
LICENSE="vim"
+SLOT="0"
VIM_PLUGIN_HELPFILES="${PN}.txt"