summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-04-14 20:54:38 +0200
committerSebastian Pipping <sping@gentoo.org>2024-04-14 20:58:40 +0200
commite00280fae4014cdeb35fabae6dd8c16ffda1f16d (patch)
treec823de918c1fd77964c061cc95652f76205ec586 /app-text
parentmedia-video/vdr: Stabilize 2.6.6 amd64, #930013 (diff)
downloadgentoo-e00280fae4014cdeb35fabae6dd8c16ffda1f16d.tar.gz
gentoo-e00280fae4014cdeb35fabae6dd8c16ffda1f16d.tar.bz2
gentoo-e00280fae4014cdeb35fabae6dd8c16ffda1f16d.zip
app-text/wiki2beamer: PEP 517 + Python 3.12
Closes: https://bugs.gentoo.org/929368 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wiki2beamer/wiki2beamer-0.10.0-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/wiki2beamer/wiki2beamer-0.10.0-r3.ebuild b/app-text/wiki2beamer/wiki2beamer-0.10.0-r3.ebuild
new file mode 100644
index 000000000000..577ba3e01b4c
--- /dev/null
+++ b/app-text/wiki2beamer/wiki2beamer-0.10.0-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit python-single-r1
+
+DESCRIPTION="Tool to produce LaTeX Beamer code from wiki-like input"
+
+MY_P=wiki2beamer-v${PV}
+HOMEPAGE="https://wiki2beamer.github.io/"
+SRC_URI="https://github.com/wiki2beamer/wiki2beamer/archive/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+ FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-ruby/asciidoctor )"
+
+S="${WORKDIR}/wiki2beamer-${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-doc-examples-makefile.patch
+ "${FILESDIR}"/${P}-doc-man-makefile.patch
+)
+
+src_compile() {
+ use doc && emake -C doc/man/ wiki2beamer.1
+}
+
+src_install() {
+ use examples && dodoc -r doc/examples
+
+ use doc && doman doc/man/${PN}.1
+ dodoc ChangeLog README.md
+
+ python_doscript code/${PN}
+}