summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-16 20:38:21 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-16 22:44:58 +0100
commitca9f5c1cd47ca415a24fe1476924a87ab841d39c (patch)
tree2c167e5dc0529e885900f3ba1cb7b4c9fb033a68 /app-text
parentdev-lang/crystal: drop old 1.10.0-r1 (diff)
downloadgentoo-ca9f5c1cd47ca415a24fe1476924a87ab841d39c.tar.gz
gentoo-ca9f5c1cd47ca415a24fe1476924a87ab841d39c.tar.bz2
gentoo-ca9f5c1cd47ca415a24fe1476924a87ab841d39c.zip
app-text/paper-clip: bump to 3.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/paper-clip/Manifest1
-rw-r--r--app-text/paper-clip/paper-clip-3.6.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-text/paper-clip/Manifest b/app-text/paper-clip/Manifest
index cb6ccceda8aa..4fb2fc181d40 100644
--- a/app-text/paper-clip/Manifest
+++ b/app-text/paper-clip/Manifest
@@ -1 +1,2 @@
DIST paper-clip-3.2.tar.gz 196899 BLAKE2B d089185db9557431c22ed64b63155920c60795315fad1901b0a5ce5fd0230b7246d375a10a8ce150ad4fdce16f9062aa4770601b741189b877e57d4fe948d7a2 SHA512 6a08fe04f3431d7444ba67da34b60d56b7cf065199fceef7086ad3f181f18c703b8d011e6dbef39942011e7f92e3728f1f1a5164a575bab43b370fca9c4fdb98
+DIST paper-clip-3.6.tar.gz 171190 BLAKE2B a31673c9c3a1f889a63561a244d966195dac2738eb4070dfd01807c7406c7f8acb0277509c6924de37068aa904c3f1ee4f6de3882bf734470b67dd77b34afcf3 SHA512 4ebfa6789d31f85dc6b38119f7fb1f88ca06a32872ab1341d4a4fcd898eb3c672673a630d56f373294c053bdcee7573206a5fe89da45b76366f65e9bb441451a
diff --git a/app-text/paper-clip/paper-clip-3.6.ebuild b/app-text/paper-clip/paper-clip-3.6.ebuild
new file mode 100644
index 000000000000..3d5055cd6861
--- /dev/null
+++ b/app-text/paper-clip/paper-clip-3.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="Paper-Clip"
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Edit the title, author, keywords and more details of PDF documents"
+HOMEPAGE="https://github.com/Diego-Ivan/Paper-Clip/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Diego-Ivan/${REAL_PN}.git"
+else
+ SRC_URI="https://github.com/Diego-Ivan/${REAL_PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${REAL_PN}-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Only validations, the appdata one fails.
+
+RDEPEND="
+ app-text/poppler:=[cairo,introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-libs/libportal:=[gtk,introspection,vala]
+ gui-libs/gtk:4
+ gui-libs/libadwaita:1[introspection,vala]
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_install() {
+ meson_src_install
+ einstalldocs
+
+ # Symlink "pdf-metadata-editor" (old name?) to "${PN}"
+ dosym -r /usr/bin/pdf-metadata-editor "/usr/bin/${PN}"
+
+ mv "${ED}/usr/share/appdata" "${ED}/usr/share/metainfo" || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}