summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-03 17:43:18 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-04 16:01:47 +0200
commitbc4ce0afbd52525d2dac28a60fb283d57016c9ef (patch)
tree2d0c3de607ba3d7c400e5c8d858ee4b7a9222e94 /app-text
parentapp-text/foliate: Update from l10n.eclass to plocale.eclass (diff)
downloadgentoo-bc4ce0afbd52525d2dac28a60fb283d57016c9ef.tar.gz
gentoo-bc4ce0afbd52525d2dac28a60fb283d57016c9ef.tar.bz2
gentoo-bc4ce0afbd52525d2dac28a60fb283d57016c9ef.zip
app-text/po4a: Update from l10n.eclass to plocale.eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/po4a/po4a-0.57.ebuild6
-rw-r--r--app-text/po4a/po4a-0.62.ebuild6
-rw-r--r--app-text/po4a/po4a-0.63.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/app-text/po4a/po4a-0.57.ebuild b/app-text/po4a/po4a-0.57.ebuild
index ba809c6f215f..08593f0289b0 100644
--- a/app-text/po4a/po4a-0.57.ebuild
+++ b/app-text/po4a/po4a-0.57.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
PLOCALES="af ar ca cs da de eo es et eu fr hr hu id it ja kn ko nb nl pl pt pt_BR ru sl sv uk vi zh_CN zh_HK"
-inherit l10n perl-module
+inherit perl-module plocale
DESCRIPTION="Tools to ease the translation of documentation"
HOMEPAGE="https://po4a.org/"
@@ -44,12 +44,12 @@ PERL_RM_FILES=(
DIST_TEST="do"
src_prepare() {
- l10n_find_plocales_changes "${S}/po/bin" '' '.po'
+ plocale_find_changes "${S}/po/bin" '' '.po'
rm_locale() {
PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
}
- l10n_for_each_disabled_locale_do rm_locale
+ plocale_for_each_disabled_locale rm_locale
perl-module_src_prepare
}
diff --git a/app-text/po4a/po4a-0.62.ebuild b/app-text/po4a/po4a-0.62.ebuild
index 6cb82437a08f..dfa0d2ba8699 100644
--- a/app-text/po4a/po4a-0.62.ebuild
+++ b/app-text/po4a/po4a-0.62.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
PLOCALES="af ar ca cs da de eo es et eu fr hr hu id it ja kn ko nb nl pl pt pt_BR ru sl sr_Cyrl sv uk vi zh_CN zh_HK"
-inherit l10n perl-module
+inherit perl-module plocale
DESCRIPTION="Tools to ease the translation of documentation"
HOMEPAGE="https://po4a.org/"
@@ -42,12 +42,12 @@ PATCHES=( "${FILESDIR}"/${PN}-0.60-man.patch )
DIST_TEST="do"
src_prepare() {
- l10n_find_plocales_changes "${S}/po/bin" '' '.po'
+ plocale_find_changes "${S}/po/bin" '' '.po'
rm_locale() {
PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
}
- l10n_for_each_disabled_locale_do rm_locale
+ plocale_for_each_disabled_locale rm_locale
perl-module_src_prepare
}
diff --git a/app-text/po4a/po4a-0.63.ebuild b/app-text/po4a/po4a-0.63.ebuild
index 6cb82437a08f..dfa0d2ba8699 100644
--- a/app-text/po4a/po4a-0.63.ebuild
+++ b/app-text/po4a/po4a-0.63.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
PLOCALES="af ar ca cs da de eo es et eu fr hr hu id it ja kn ko nb nl pl pt pt_BR ru sl sr_Cyrl sv uk vi zh_CN zh_HK"
-inherit l10n perl-module
+inherit perl-module plocale
DESCRIPTION="Tools to ease the translation of documentation"
HOMEPAGE="https://po4a.org/"
@@ -42,12 +42,12 @@ PATCHES=( "${FILESDIR}"/${PN}-0.60-man.patch )
DIST_TEST="do"
src_prepare() {
- l10n_find_plocales_changes "${S}/po/bin" '' '.po'
+ plocale_find_changes "${S}/po/bin" '' '.po'
rm_locale() {
PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
}
- l10n_for_each_disabled_locale_do rm_locale
+ plocale_for_each_disabled_locale rm_locale
perl-module_src_prepare
}