summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-02-13 17:50:53 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-02-13 17:50:53 +0700
commitb0677fa281ffb89147338c2896ef63c04a2846e6 (patch)
treee42580cc3c46e10cf71c7aed713d11c574598fd6 /app-text
parentapp-text/crengine-ng: current snapshot (diff)
downloadgentoo-b0677fa281ffb89147338c2896ef63c04a2846e6.tar.gz
gentoo-b0677fa281ffb89147338c2896ef63c04a2846e6.tar.bz2
gentoo-b0677fa281ffb89147338c2896ef63c04a2846e6.zip
app-text/crqt-ng: current snapshot
Selected text is now copied to X primary selection Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/crqt-ng/Manifest1
-rw-r--r--app-text/crqt-ng/crqt-ng-1.0.12_p1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/crqt-ng/Manifest b/app-text/crqt-ng/Manifest
index b9ac89ace2d7..015d22087f31 100644
--- a/app-text/crqt-ng/Manifest
+++ b/app-text/crqt-ng/Manifest
@@ -1,2 +1,3 @@
DIST crqt-ng-1.0.11.tar.bz2 442916 BLAKE2B 3eb4c73f1c3b3c88d92cb6ed5bf4895329caab1391c7be05dc0ccc1a65546f7761ee7af6246045be70137fd8683e2bfc5fb41df3dad604177ae4c0351f44c74e SHA512 62bb4b8a3dec3dd9fba5e1a2795f384e5310b87800d89e15b7f4fe258eb923481f1264ec23645b09f5ae89822e332d1499aeca0a79efab21124b43deec3ada44
DIST crqt-ng-1.0.12.tar.bz2 443646 BLAKE2B 338c96a9c34d6a05ed6fa9cd1d6fe63665518e8c12e835a7fba22b81585116f9e579b326c9fc22a67d7225f0ca4cc15035179be923507b0af7032666f05d972e SHA512 24258c32dac6ba24833d7a6a227cef6dfb39ff415781921c90e57cd9c73ce187255bcffee3b38719b38dde2f6cb8a0569f5b25db88688c105f8b24246676207d
+DIST crqt-ng-1.0.12_p1.tar.bz2 431000 BLAKE2B dd84ecafc2f3ca866c4462e67937bb82757f45112cc1cfe341df08e354bced64c680b378d5fe1f4ce0ba5db48f16511771c7053119b5abf5916101b999ceb80f SHA512 47e2b2d882ceb81bb68971fcb39dc770bd067f30b86c0e3ac8c3aa4599e1780b4cf595fa1c84f41f9ffa0bbbd9f4136ea974be72dd3b9106856b6c480b7300f7
diff --git a/app-text/crqt-ng/crqt-ng-1.0.12_p1.ebuild b/app-text/crqt-ng/crqt-ng-1.0.12_p1.ebuild
new file mode 100644
index 000000000000..399b79d5e588
--- /dev/null
+++ b/app-text/crqt-ng/crqt-ng-1.0.12_p1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="bg cs hu nl ru uk"
+inherit cmake plocale xdg
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crqt-ng"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${CDEPEND}"
+BDEPEND="${CDEPEND}
+ dev-qt/linguist-tools:5"
+
+src_prepare() {
+ cmake_src_prepare
+ xdg_environment_reset
+
+ # locales
+ plocale_find_changes "${S}"/src/i18n 'crqt_' '.ts'
+ sed -e "s|set(LANGUAGES .*)|set(LANGUAGES $(plocale_get_locales))|i" \
+ -i "${S}"/src/CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(-DUSE_QT=QT5)
+ cmake_src_configure
+}