summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-10 12:35:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-10 12:36:05 +0200
commit7a2c4ef473ba9bcca4126a23ad4b6149746fb565 (patch)
treedf99fba5cfb1ccaed62636ee0d3a20331ce6e5e4 /app-text
parentprofiles: drop deprecated 13.0 profiles, bug #672960 (diff)
downloadgentoo-7a2c4ef473ba9bcca4126a23ad4b6149746fb565.tar.gz
gentoo-7a2c4ef473ba9bcca4126a23ad4b6149746fb565.tar.bz2
gentoo-7a2c4ef473ba9bcca4126a23ad4b6149746fb565.zip
app-text/writerperfect: Fix build with USE gsf
Closes: https://bugs.gentoo.org/687788 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/writerperfect/files/writerperfect-0.9.6-gsf-buildfix.patch14
-rw-r--r--app-text/writerperfect/writerperfect-0.9.6.ebuild10
2 files changed, 20 insertions, 4 deletions
diff --git a/app-text/writerperfect/files/writerperfect-0.9.6-gsf-buildfix.patch b/app-text/writerperfect/files/writerperfect-0.9.6-gsf-buildfix.patch
new file mode 100644
index 000000000000..0c689ec0b7fc
--- /dev/null
+++ b/app-text/writerperfect/files/writerperfect-0.9.6-gsf-buildfix.patch
@@ -0,0 +1,14 @@
+fix build with libgsf
+Authored by: David Tardon 2017-12-14
+
+--- a/src/lib/OutputFileHelper.cxx
++++ b/src/lib/OutputFileHelper.cxx
+@@ -57,7 +57,7 @@
+ OutputFileHelperImpl::~OutputFileHelperImpl()
+ {
+ #ifdef USE_GSF_OUTPUT
+- if (mpOutfile && !gsf_output_close((GsfOutput *) mpOutfile.get()))
++ if (mpOutfile && !gsf_output_close((GsfOutput *) mpOutfile))
+ fprintf(stderr, "ERROR : Couldn't close outfile\n");
+
+ if (mpOutfile)
diff --git a/app-text/writerperfect/writerperfect-0.9.6.ebuild b/app-text/writerperfect/writerperfect-0.9.6.ebuild
index b6dba7c029d1..4079835b3f7f 100644
--- a/app-text/writerperfect/writerperfect-0.9.6.ebuild
+++ b/app-text/writerperfect/writerperfect-0.9.6.ebuild
@@ -12,6 +12,11 @@ SLOT="0"
KEYWORDS="amd64 ~x86 ~x86-linux ~x86-solaris"
IUSE="abiword +cdr debug ebook epub freehand gsf keynote +mspub +mwaw pagemaker qxp +visio +wpd +wpg +wps zmf"
+# configure fails if no import library is selected...
+REQUIRED_USE="
+ || ( abiword cdr ebook freehand keynote mspub mwaw pagemaker qxp visio wpd wpg wps zmf )
+"
+
# FIXME: librvngabw
BDEPEND="
virtual/pkgconfig
@@ -39,10 +44,7 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-REQUIRED_USE="
- || ( abiword cdr ebook freehand keynote mspub mwaw pagemaker qxp visio wpd wpg wps zmf )
-"
-# configure fails if no import library is selected...
+PATCHES=( "${FILESDIR}/${P}-gsf-buildfix.patch" )
src_configure() {
local myeconfargs=(