summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-11-01 11:49:37 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-11-01 11:49:37 +0100
commit2bb6ceb40fbdc26c219f17051768006936832e26 (patch)
tree3a59075d8b7bbca34e435bff9207268e59b3d7f9 /app-text
parentdev-python/spyder: add 6.0.2 (diff)
downloadgentoo-2bb6ceb40fbdc26c219f17051768006936832e26.tar.gz
gentoo-2bb6ceb40fbdc26c219f17051768006936832e26.tar.bz2
gentoo-2bb6ceb40fbdc26c219f17051768006936832e26.zip
app-text/zotero-bin: add 7.0.9
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-7.0.9.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index f7e43082bf06..cdb3d3fecd9b 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -2,3 +2,5 @@ DIST zotero-bin-7.0.5-amd64.tar.bz2 109076934 BLAKE2B c1c685648a887e57fad7499b7e
DIST zotero-bin-7.0.5-x86.tar.bz2 113004962 BLAKE2B b92719cf66045c7b2ca4c7108822b510583629b6886a0a16676b1cb4ff7302ea303f94410f24f378909a7ff55bb3d459bdedfce0e1de4bd32a8db921548c7bd2 SHA512 21ed0b6fa088ce92699a271ef64171c583fa669e42cb6517e3b0238294ddcfed80a3d001a928dfb3916ad41b04f70d08bad065741e7f4caa98978ad4b1b6fa4f
DIST zotero-bin-7.0.7-amd64.tar.bz2 109119371 BLAKE2B ec4530c36bf909b81b2b537bb7feac4a5c69584478a8eb8545d1f517ed9a00ffeb988aafe71fd5646fd253a97195b2e3d2f3ea6e6695c57621b3cd08c1e6ad4b SHA512 0fdb946478cdad09169c3e0ccb58a976d0bc7f08e82b43f0016404c0e369ba59cb077e2d27d568d4bb9fab0831c42834c2c4e93d2f78e4dbf233fd2e2f76001f
DIST zotero-bin-7.0.7-x86.tar.bz2 113050907 BLAKE2B c0d975bde1b330f566f1bbfe203e5458230b803c8611bfd9878483727baba6703dad621a2fea892dfb152399b928f697e40963714f445affd43c3fc8dc98a589 SHA512 bb931cf0115516c7a870b6ec61f2f73b7be5d768fde4cb7a0120bbad40b5284667c8b2cd2aac9d06d7e1701c1fcecb8ca4376f76f8556e9dcb1b9ffe76cc9b7d
+DIST zotero-bin-7.0.9-amd64.tar.bz2 109258993 BLAKE2B 31543016f0c3e5635b7e63a1a5180bc09e9f10d80f9f190a2bab4e419f480cc018998cbc974fe0b5c20875057ad6e635bebfa8fcc7a4121a888b22dc90e66c37 SHA512 d8ca1012284c50d6a574ff13bae8e3422e7a04c7fd0002c04b757789e261e40731fe86edd2cf5144987e02f2b24e8f37336710e13812cceab941b6498bdea7d2
+DIST zotero-bin-7.0.9-x86.tar.bz2 113192202 BLAKE2B ecf0f361e3b570e60b190a4bfbfa7da9b739a08f429b3694479a65f4a7e1aa98e70e42ed23b77fa5c13a8edc4a0bcd13381b0b04352ccf41b189a3d458689ce6 SHA512 75fc41054888e403704d36998402e4b4bde44619229b01e847ca438aac02e23c08fb63cd3adaeb29fe6c21796e0001280f989cdffb1cc4cf4ac7bd51fefb4a72
diff --git a/app-text/zotero-bin/zotero-bin-7.0.9.ebuild b/app-text/zotero-bin/zotero-bin-7.0.9.ebuild
new file mode 100644
index 000000000000..56e522c44ad2
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-7.0.9.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="
+ amd64? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-amd64.tar.bz2 )
+ x86? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-i686&version=${PV} -> ${P}-x86.tar.bz2 )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ # disable auto-update
+ sed -i -e 's#URL=.*#URL=#' app/application.ini || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero -url %U#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ dodir opt/zotero
+ cp -a * "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 32 64 128; do
+ newicon -s ${size} icons/icon${size}.png zotero.png
+ done
+}